summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-31 17:13:56 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-31 17:13:56 (GMT)
commit71e5b546b03a607f21fe6859dc3ecbf7968937ee (patch)
treeb079081f1a98161ca343ea4b248150c3c25bf5b5 /abs/core/perl_modules
parent93f3a4de3fbcf73680b27a4cae0c9cee53d35613 (diff)
downloadlinhes_pkgbuild-71e5b546b03a607f21fe6859dc3ecbf7968937ee.zip
linhes_pkgbuild-71e5b546b03a607f21fe6859dc3ecbf7968937ee.tar.gz
linhes_pkgbuild-71e5b546b03a607f21fe6859dc3ecbf7968937ee.tar.bz2
perl-unicode-utf8simple: rebuild
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-unicode-utf8simple/PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/abs/core/perl_modules/perl-unicode-utf8simple/PKGBUILD b/abs/core/perl_modules/perl-unicode-utf8simple/PKGBUILD
index a5b9dfb..b3fb861 100644
--- a/abs/core/perl_modules/perl-unicode-utf8simple/PKGBUILD
+++ b/abs/core/perl_modules/perl-unicode-utf8simple/PKGBUILD
@@ -1,23 +1,29 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Allan McRae <mcrae_allan@hotmail.com>
# Contributor: François Charette <firmicus ατ gmx δοτ net>
pkgname=perl-unicode-utf8simple
pkgver=1.06
-pkgrel=2
+pkgrel=6
pkgdesc="Conversions to/from UTF8 from/to characterse"
-arch=('i686' 'x86_64')
-url="http://search.cpan.org/~GUS/Unicode-UTF8simple"
+arch=('any')
+url="http://search.cpan.org/dist/Unicode-UTF8simple"
license=('GPL' 'PerlArtistic')
depends=('perl>=5.10.0')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/G/GU/GUS/Unicode-UTF8simple-$pkgver.tar.gz)
-md5sums=('1d90907170ed41690a572a2d6ed6e7da')
+source=(https://www.cpan.org/authors/id/G/GU/GUS/Unicode-UTF8simple-$pkgver.tar.gz)
+sha256sums=('e1249ac08daceb8a83c170c00810001f15d73418e9595711bee663d0130c0fe5')
build() {
- cd $startdir/src/Unicode-UTF8simple-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=$startdir/pkg || return 1
- find $startdir/pkg -name '.packlist' -delete
- find $startdir/pkg -name '*.pod' -delete
+ cd "$srcdir"/Unicode-UTF8simple-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir"/Unicode-UTF8simple-$pkgver
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
}