summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-07 01:43:49 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-07 01:43:49 (GMT)
commit8cbc01df83dbb5d1d60d8d375586ec351437a06c (patch)
tree0301ba898811eb8d091d41c2f0d7dffd43710bf9 /abs/core/perl_modules
parentca13f9d44cf30d733e376d95a2119653bdcdb7fd (diff)
downloadlinhes_pkgbuild-8cbc01df83dbb5d1d60d8d375586ec351437a06c.zip
linhes_pkgbuild-8cbc01df83dbb5d1d60d8d375586ec351437a06c.tar.gz
linhes_pkgbuild-8cbc01df83dbb5d1d60d8d375586ec351437a06c.tar.bz2
perl-xml-parser: upgrade
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-xml-parser/PKGBUILD57
1 files changed, 35 insertions, 22 deletions
diff --git a/abs/core/perl_modules/perl-xml-parser/PKGBUILD b/abs/core/perl_modules/perl-xml-parser/PKGBUILD
index cf2f801..78c404d 100644
--- a/abs/core/perl_modules/perl-xml-parser/PKGBUILD
+++ b/abs/core/perl_modules/perl-xml-parser/PKGBUILD
@@ -1,25 +1,38 @@
-# This PKGBUILD was autocreated. See http://xtermin.us/archperl/ for details
-# Maintainer: Charles Mauch <cmauch@gmail.com>
+# $Id: PKGBUILD 99293 2010-11-13 20:13:13Z andrea $
+# Maintainer:
+# Contributor: firmicus <francois@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: herb <hrose@archlinux.org>
+
pkgname=perl-xml-parser
-pkgver=2.34
-pkgrel=3
-pkgdesc="Perl/CPAN Module XML::Parser : Flexible fast parser with plugin styles"
-arch=("i686" "x86_64")
-url="http://search.cpan.org/MSERGEANT/XML-Parser"
-license=("GPL" "Artistic")
-source=("http://www.cpan.org/authors/id/M/MS/MSERGEANT/XML-Parser-2.34.tar.gz")
-md5sums=("84d9e0001fe01c14867256c3fe115899")
+_realname=XML-Parser
+pkgver=2.40
+pkgrel=1
+pkgdesc="Expat-based XML parser module for perl"
+arch=('i686' 'x86_64')
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/dist/${_realname}/"
+depends=('perl' 'expat')
+replaces=('perlxml')
+provides=("perlxml=${pkgver}")
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/C/CH/CHORNY/${_realname}-${pkgver}.tar.gz")
+md5sums=('c66e9adba003d0667cc40115ccd837a5')
+
build() {
- cd $startdir/src/XML-Parser-2.34
- eval `perl -V:archname`
- /usr/bin/perl Makefile.PL \
- INSTALLARCHLIB=/usr/lib/perl5/current/${archname} \
- INSTALLSITELIB=/usr/lib/perl5/site_perl/current \
- INSTALLSITEARCH=/usr/lib/perl5/site_perl/current/${archname} || return 1
- make || return 1
- make DESTDIR=$startdir/pkg install || return 1
- /usr/bin/find $startdir/pkg -name '.packlist' -exec rm '{}' \; && \
- /usr/bin/find $startdir/pkg -name 'perllocal.pod' -exec rm '{}' \; && \
- /usr/bin/find $startdir/pkg -depth -type d -empty -exec rmdir '{}' \;
- rm -fr $pkgdir/usr/share/man
+ cd "${srcdir}/${_realname}-${pkgver}"
+
+ # install module in vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
}
+
+package() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+
+ # remove perllocal.pod and .packlist.
+ find "${pkgdir}" -name perllocal.pod -delete
+ find "${pkgdir}" -name .packlist -delete
+}
+