summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-17 03:37:42 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-17 03:37:42 (GMT)
commit90049936b54450159b86ed408d0e2eb444da62b5 (patch)
tree25557af32408e1df0479eb13e283d644dbeaecdb /abs/core/perl_modules
parent4133e9a70bc3ac2ce4cca7c2619c3c893dfdda15 (diff)
downloadlinhes_pkgbuild-90049936b54450159b86ed408d0e2eb444da62b5.zip
linhes_pkgbuild-90049936b54450159b86ed408d0e2eb444da62b5.tar.gz
linhes_pkgbuild-90049936b54450159b86ed408d0e2eb444da62b5.tar.bz2
perl-dbd-mysql: ensuring we have this (mythtv dep)
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-dbd-mysql/PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/abs/core/perl_modules/perl-dbd-mysql/PKGBUILD b/abs/core/perl_modules/perl-dbd-mysql/PKGBUILD
index c6e4cb8..03e801a 100644
--- a/abs/core/perl_modules/perl-dbd-mysql/PKGBUILD
+++ b/abs/core/perl_modules/perl-dbd-mysql/PKGBUILD
@@ -1,29 +1,34 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 82506 2010-06-12 19:27:47Z kevin $
# Maintainer: Kevin Piche <kevin@archlinux.org>
# Contributor: Eric Johnson <eric@coding-zone.com>
pkgname=perl-dbd-mysql
_realname=DBD-mysql
-pkgver=4.006
-pkgrel=1
+pkgver=4.014
+pkgrel=2
pkgdesc="Perl/CPAN DBD::mysql module for interacting with MySQL via DBD"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('GPL' 'PerlArtistic')
url="http://search.cpan.org/dist/${_realname}/"
depends=('libmysqlclient' 'perl-dbi' 'perl>=5.10.0')
makedepends=('mysql')
options=(!emptydirs)
source=(http://search.cpan.org/CPAN/authors/id/C/CA/CAPTTOFU/${_realname}-${pkgver}.tar.gz)
-md5sums=('133ac08c22bb19194ad8b895e3204310')
+md5sums=('74f118a4984e6a49f8ece28e68caf543')
build() {
- cd ${startdir}/src/${_realname}-${pkgver}
+ cd ${srcdir}/${_realname}-${pkgver}
+
# install module in vendor directories.
perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=${startdir}/pkg || return 1
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/${_realname}-${pkgver}
+ make install DESTDIR=${pkgdir} || return 1
# remove perllocal.pod and .packlist
- find ${startdir}/pkg -name perllocal.pod -delete
- find ${startdir}/pkg -name .packlist -delete
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
}