summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-03-24 18:03:50 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-03-24 18:03:50 (GMT)
commitad829ff83184244b4b0c95aaf38462069dea9a6c (patch)
treef79b1f068125102bedade0ec927781d087bd1989 /abs/core/perl_modules
parentc57dddb5025603ee431374f9d33de07f27eed6cb (diff)
downloadlinhes_pkgbuild-ad829ff83184244b4b0c95aaf38462069dea9a6c.zip
linhes_pkgbuild-ad829ff83184244b4b0c95aaf38462069dea9a6c.tar.gz
linhes_pkgbuild-ad829ff83184244b4b0c95aaf38462069dea9a6c.tar.bz2
perl-io-socket-multicast: initial inclusion. dep of zoneminder
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-io-socket-multicast/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-io-socket-multicast/PKGBUILD b/abs/core/perl_modules/perl-io-socket-multicast/PKGBUILD
new file mode 100644
index 0000000..5bf7764
--- /dev/null
+++ b/abs/core/perl_modules/perl-io-socket-multicast/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=perl-io-socket-multicast
+pkgver=1.12
+pkgrel=2
+pkgdesc="IO::Socket::Multicast - Object interface to socket communications for perl"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url="http://search.cpan.org/dist/IO-Socket-Multicast/"
+source=("http://search.cpan.org/CPAN/authors/id/B/BR/BRAMBLE/IO-Socket-Multicast-$pkgver.tar.gz")
+md5sums=('c96e6cbb367b1d11ffe7bb9fbd833540')
+
+build() {
+ cd "$srcdir/IO-Socket-Multicast-$pkgver"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/IO-Socket-Multicast-$pkgver"
+ make DESTDIR=$pkgdir install
+}