summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-10-27 21:00:41 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-10-27 21:00:41 (GMT)
commitae1fc420e06161358998766d6ce671b5863332c0 (patch)
treeafa9ea15df501215d1aae5cccf628b2415d43973 /abs/core/perl_modules
parent13e448167b66c3e73c11d68962032d96e02f9791 (diff)
downloadlinhes_pkgbuild-ae1fc420e06161358998766d6ce671b5863332c0.zip
linhes_pkgbuild-ae1fc420e06161358998766d6ce671b5863332c0.tar.gz
linhes_pkgbuild-ae1fc420e06161358998766d6ce671b5863332c0.tar.bz2
recompile perl-error python-gitdb
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-error/PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/abs/core/perl_modules/perl-error/PKGBUILD b/abs/core/perl_modules/perl-error/PKGBUILD
index 2a4437c..a8fa056 100644
--- a/abs/core/perl_modules/perl-error/PKGBUILD
+++ b/abs/core/perl_modules/perl-error/PKGBUILD
@@ -1,35 +1,34 @@
-# $Id$
+# $Id: PKGBUILD 163573 2012-07-16 03:20:23Z eric $
# Maintainer: Dale Blount <dale@archlinux.org>
# Contributor: Dale Blount <dale@archlinux.org>
pkgname=perl-error
_realname=Error
-pkgver=0.17016
-pkgrel=2
+pkgver=0.17018
+pkgrel=1
pkgdesc="Perl/CPAN Error module - Error/exception handling in an OO-ish way"
url="http://search.cpan.org/dist/${_realname}/"
-arch=(any)
+arch=('any')
license=('PerlArtistic' 'GPL')
depends=('perl>=5.10.0')
options=('!emptydirs')
source=(http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/${_realname}-${pkgver}.tar.gz)
-md5sums=('eedcd3c6970568dd32092b5334328eff')
build() {
- cd ${srcdir}/${_realname}-${pkgver}
+ cd "${srcdir}/${_realname}-${pkgver}"
# install module in vendor directories.
perl Makefile.PL INSTALLDIRS=vendor
make
+}
+
+check() {
+ cd "${srcdir}/${_realname}-${pkgver}"
make test
}
package() {
- cd ${srcdir}/${_realname}-${pkgver}
-
- make install DESTDIR=${pkgdir}
-
- # remove perllocal.pod and .packlist
- find ${pkgdir} -name perllocal.pod -delete
- find ${pkgdir} -name .packlist -delete
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make install DESTDIR="${pkgdir}"
}
+md5sums=('1137a7bbb94c9508a2268c467583207f')