summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-31 16:42:08 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-31 16:42:08 (GMT)
commitb4bfc37d84a31854afff21bb4f81fdd7421ec637 (patch)
tree7dcc720152afd35ecbfecf7aca062bc797ecf79c /abs/core/perl_modules
parent27851d651a71eec8a45839916d6a89c1b2d5c471 (diff)
downloadlinhes_pkgbuild-b4bfc37d84a31854afff21bb4f81fdd7421ec637.zip
linhes_pkgbuild-b4bfc37d84a31854afff21bb4f81fdd7421ec637.tar.gz
linhes_pkgbuild-b4bfc37d84a31854afff21bb4f81fdd7421ec637.tar.bz2
perl-text-iconv: rebuild
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-text-iconv/PKGBUILD36
1 files changed, 25 insertions, 11 deletions
diff --git a/abs/core/perl_modules/perl-text-iconv/PKGBUILD b/abs/core/perl_modules/perl-text-iconv/PKGBUILD
index 1e35fce..b9ab604 100644
--- a/abs/core/perl_modules/perl-text-iconv/PKGBUILD
+++ b/abs/core/perl_modules/perl-text-iconv/PKGBUILD
@@ -1,25 +1,39 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: damir <damir@archlinux.org>
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Francois Charette <firmicus@gmx.net>
pkgname=perl-text-iconv
_realname=Text-Iconv
pkgver=1.7
-pkgrel=2
+pkgrel=14
pkgdesc="Interface to iconv codeset conversion"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://search.cpan.org/dist/${_realname}/"
license=('GPL' 'PerlArtistic')
-depends=('perl>=5.10.0')
+depends=('perl')
options=('!emptydirs')
source=(http://www.cpan.org/authors/id/M/MP/MPIOTR/${_realname}-${pkgver}.tar.gz)
md5sums=('81b26e069eaebb084e91ea3c009b67ae')
build() {
- cd ${startdir}/src/${_realname}-${pkgver}
- perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
- find ${startdir}/pkg -name '.packlist' -delete
- find ${startdir}/pkg -name '*.pod' -delete
+ cd "${srcdir}/${_realname}-${pkgver}"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+ _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+ _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+ depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
}