summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-31 17:10:39 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-31 17:10:39 (GMT)
commitc4613a7d73982d053f1ac7417a9ace5ba2d03644 (patch)
treef3fe87592b15e16e1c46cba64052dadcc0df8a47 /abs/core/perl_modules
parentc266250679ac51eba3cd2ef6aa98ad731709e199 (diff)
downloadlinhes_pkgbuild-c4613a7d73982d053f1ac7417a9ace5ba2d03644.zip
linhes_pkgbuild-c4613a7d73982d053f1ac7417a9ace5ba2d03644.tar.gz
linhes_pkgbuild-c4613a7d73982d053f1ac7417a9ace5ba2d03644.tar.bz2
perl-unicode-map: rebuild
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-unicode-map/PKGBUILD62
1 files changed, 41 insertions, 21 deletions
diff --git a/abs/core/perl_modules/perl-unicode-map/PKGBUILD b/abs/core/perl_modules/perl-unicode-map/PKGBUILD
index 1d03e86..d3dc5ef 100644
--- a/abs/core/perl_modules/perl-unicode-map/PKGBUILD
+++ b/abs/core/perl_modules/perl-unicode-map/PKGBUILD
@@ -1,30 +1,50 @@
-# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
-# Contributor: Ross melin <rdmelin@gmail.com>
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.27
-# Required by zoneminder
-
-pkgname=perl-unicode-map
-pkgver=0.112
-pkgrel=2
-pkgdesc="Unicode::Map"
+pkgname='perl-unicode-map'
+pkgver='0.112'
+pkgrel='3'
+pkgdesc="V0.112 - maps charsets from and to utf16 unicode "
arch=('i686' 'x86_64')
-url="http://search.cpan.org/~MSCHWARTZ/Unicode-Map"
-license=('GPL' 'PerlArtistic')
-depends=('perl')
+license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/M/MS/MSCHWARTZ/Unicode-Map-$pkgver.tar.gz)
+depends=('perl>=0')
+makedepends=()
+url='http://search.cpan.org/dist/Unicode-Map'
+source=('http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWARTZ/Unicode-Map-0.112.tar.gz')
md5sums=('edaa8fc5ddf0e5d805e274283dd0625d')
+sha512sums=('f66961ee84db7316289176cf43ddb8366ecfaf614130f8b1018931a92b96d16a97f231da6fdd1d8c1bd95ddd50f4b93d82ff87affbbd1162c894b1f302f27d4f')
+_distdir="Unicode-Map-0.112"
build() {
- cd $startdir/src/Unicode-Map-$pkgver
- eval `perl -V:archname`
- PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
- INSTALLDIRS=vendor || return 1
-
- /usr/bin/make || return 1
- /usr/bin/make DESTDIR=$startdir/pkg install || return 1
- /usr/bin/find $startdir/pkg -name '.packlist' -delete
- /usr/bin/find $startdir/pkg -name '*.pod' -delete
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
# vim:set ts=2 sw=2 et: