summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-30 19:49:51 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-30 19:49:51 (GMT)
commitcc8a3a47e9a9d71f73281a90d409b69000243052 (patch)
tree1b1b20dd91cb7448f0cd1042b4eca170dbfe4664 /abs/core/perl_modules
parent815faa8733128ecf29991a162de7f57ec2814ed2 (diff)
downloadlinhes_pkgbuild-cc8a3a47e9a9d71f73281a90d409b69000243052.zip
linhes_pkgbuild-cc8a3a47e9a9d71f73281a90d409b69000243052.tar.gz
linhes_pkgbuild-cc8a3a47e9a9d71f73281a90d409b69000243052.tar.bz2
perl-sub-identify: initial
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-sub-identify/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-sub-identify/PKGBUILD b/abs/core/perl_modules/perl-sub-identify/PKGBUILD
new file mode 100644
index 0000000..b428187
--- /dev/null
+++ b/abs/core/perl_modules/perl-sub-identify/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+
+pkgname=perl-sub-identify
+pkgver=0.14
+pkgrel=4
+pkgdesc="Retrieve names of code references"
+arch=('x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+checkdepends=('perl-test-pod')
+url='http://search.mcpan.org/dist/Sub-Identify'
+source=("http://search.mcpan.org/CPAN/authors/id/R/RG/RGARCIA/Sub-Identify-$pkgver.tar.gz")
+sha512sums=('f69f542c84c5c3ca1f1c7f5f58fd2cf19279a65229f43117c31f24ab0e49d5f329bef2bc00f22252fd2e52b4e17f16b279dac438920668e046e59f2e22e52c14')
+
+build() {
+ cd "$srcdir/Sub-Identify-$pkgver"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/Sub-Identify-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/Sub-Identify-$pkgver"
+ make DESTDIR="$pkgdir"/ install
+}
+
+# vim:set ts=2 sw=2 et: