summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-07-05 03:13:41 (GMT)
committerCecil <knoppmyth@gmail.com>2011-07-05 03:13:41 (GMT)
commitce1750c795d0db0b0beadf52c2ef5265c3680bab (patch)
tree3f8ee555c55afcdd4139bbcc1d900220a7343bef /abs/core/perl_modules
parentb86d19a012d9d6b1c4258b79cb67da59e5fdb5f1 (diff)
downloadlinhes_pkgbuild-ce1750c795d0db0b0beadf52c2ef5265c3680bab.zip
linhes_pkgbuild-ce1750c795d0db0b0beadf52c2ef5265c3680bab.tar.gz
linhes_pkgbuild-ce1750c795d0db0b0beadf52c2ef5265c3680bab.tar.bz2
perl-datetime:Bumped to latest.
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-datetime/PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/abs/core/perl_modules/perl-datetime/PKGBUILD b/abs/core/perl_modules/perl-datetime/PKGBUILD
index 0e6fbaa..0b32ce3 100644
--- a/abs/core/perl_modules/perl-datetime/PKGBUILD
+++ b/abs/core/perl_modules/perl-datetime/PKGBUILD
@@ -1,23 +1,29 @@
-# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# $Id: PKGBUILD 31942 2010-11-08 11:04:10Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: François Charette <firmicus ατ gmx δοτ net>
pkgname=perl-datetime
-pkgver=0.47
+pkgver=0.65
pkgrel=1
pkgdesc="A complete, easy to use date and time object"
arch=('i686' 'x86_64')
-url="http://search.cpan.org/~DROLSKY/DateTime"
+url="http://search.cpan.org/dist/DateTime"
license=('GPL' 'PerlArtistic')
depends=('perl-datetime-timezone>=0.59' 'perl-datetime-locale>=0.41' 'perl-params-validate>=0.76')
+LC_NUMERIC=C
+provides=("perl-datetime=`printf %.4f $pkgver`")
options=('!emptydirs' 'force')
-source=(http://www.cpan.org/authors/id/D/DR/DROLSKY/DateTime-$pkgver.tar.gz)
-md5sums=('9d2ee69f93f18f7e5477578df6e56526')
+source=(http://www.cpan.org/authors/id/D/DR/DROLSKY/DateTime-$pkgver.tar.gz)
+md5sums=('99fd327152d3a462ba575c8c74d5cb65')
build() {
- cd $startdir/src/DateTime-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=$startdir/pkg || return 1
- find $startdir/pkg -name '.packlist' -delete
- find $startdir/pkg -name '*.pod' -delete
+ cd $srcdir/DateTime-$pkgver
+
+ perl Build.PL installdirs=vendor destdir="$pkgdir/"
+ ./Build
+# ./Build test
+ ./Build install
+
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
}