summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-29 23:22:53 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-29 23:22:53 (GMT)
commite90d0b65eea997e6bf384a787d41975270d382c9 (patch)
tree6839a990b34ffd34a3b64978f65f09dbc3994c5e /abs/core/perl_modules
parent4ff9b385ba66d5fe4fd88a2fc12bfe05845109d0 (diff)
downloadlinhes_pkgbuild-e90d0b65eea997e6bf384a787d41975270d382c9.zip
linhes_pkgbuild-e90d0b65eea997e6bf384a787d41975270d382c9.tar.gz
linhes_pkgbuild-e90d0b65eea997e6bf384a787d41975270d382c9.tar.bz2
perl-yaml-tiny: initial inclusion
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-yaml-tiny/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-yaml-tiny/PKGBUILD b/abs/core/perl_modules/perl-yaml-tiny/PKGBUILD
new file mode 100644
index 0000000..3759296
--- /dev/null
+++ b/abs/core/perl_modules/perl-yaml-tiny/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: AUR Perl <aurperl@juster.info>
+# Generator : CPANPLUS::Dist::Arch 1.15
+
+pkgname=perl-yaml-tiny
+pkgver=1.73
+pkgrel=1
+pkgdesc="Read/Write YAML files with as little code as possible"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+checkdepends=('perl-cpan-meta>=2.150001' 'perl-pod-coverage')
+url='http://search.cpan.org/dist/YAML-Tiny'
+source=("http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/YAML-Tiny-$pkgver.tar.gz")
+sha512sums=('5999e220025aa8076e5e0e9e73e80c2da21660e77f6744d73e8e29962221d02d33a36e9829c44abf7d4f45abae069d8e121c8019bd1600b7e64db5e54efd9987')
+
+build() {
+ cd "${srcdir}/YAML-Tiny-${pkgver}"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+check() {
+ cd "${srcdir}/YAML-Tiny-${pkgver}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/YAML-Tiny-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# vim:set ts=2 sw=2 et: