summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-30 19:29:56 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-30 19:29:56 (GMT)
commitefbd4ba3fd3d4a7e5c78b4397fdf40d42dc9e1ad (patch)
tree6953d4a2c31170838848437581c9fb433b5c1768 /abs/core/perl_modules
parent98ed26c0537a50b3ecc5dd28ba02e2425157bfaa (diff)
downloadlinhes_pkgbuild-efbd4ba3fd3d4a7e5c78b4397fdf40d42dc9e1ad.zip
linhes_pkgbuild-efbd4ba3fd3d4a7e5c78b4397fdf40d42dc9e1ad.tar.gz
linhes_pkgbuild-efbd4ba3fd3d4a7e5c78b4397fdf40d42dc9e1ad.tar.bz2
perl-params-validate: update to 1.29
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-params-validate/PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/abs/core/perl_modules/perl-params-validate/PKGBUILD b/abs/core/perl_modules/perl-params-validate/PKGBUILD
index b14f42d..accfb83 100644
--- a/abs/core/perl_modules/perl-params-validate/PKGBUILD
+++ b/abs/core/perl_modules/perl-params-validate/PKGBUILD
@@ -1,27 +1,35 @@
-# $Id: PKGBUILD 71825 2012-06-02 10:31:58Z bluewind $
+# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: François Charette <firmicus ατ gmx δοτ net>
pkgname=perl-params-validate
-pkgver=1.06
-pkgrel=3
+pkgver=1.29
+pkgrel=1
pkgdesc="Validate sub params against a spec"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://search.cpan.org/dist/Params-Validate"
license=('GPL' 'PerlArtistic')
depends=('perl' 'perl-module-implementation')
+makedepends=('perl-module-build')
options=('!emptydirs')
-source=("http://www.cpan.org/authors/id/D/DR/DROLSKY/Params-Validate-${pkgver}.tar.gz")
-md5sums=('4f7a281269cd30d7c3994ba5acb50857')
+source=("https://www.cpan.org/authors/id/D/DR/DROLSKY/Params-Validate-${pkgver}.tar.gz")
+sha256sums=('49a68dfb430bea028042479111d19068e08095e5a467e320b7ab7bde3d729733')
build() {
cd Params-Validate-${pkgver}
perl ./Build.PL --installdirs=vendor
./Build
}
-package(){
+package() {
cd Params-Validate-${pkgver}
- ./Build install --destdir=${pkgdir}
- find ${pkgdir} -name '.packlist' -delete
- find ${pkgdir} -name '*.pod' -delete
+ ./Build install --destdir="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+ _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+ _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+ depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
}