summaryrefslogtreecommitdiffstats
path: root/abs/core/perl_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-05-31 15:56:15 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-05-31 15:56:15 (GMT)
commitf45fec4bab0e4922c6e31b26e1a8216451f62a14 (patch)
tree8f991ba6d34afa9e3d485e02ea2996012b036ebf /abs/core/perl_modules
parent709ef5d8222b49ec4b4b398530a7efaf1082b032 (diff)
downloadlinhes_pkgbuild-f45fec4bab0e4922c6e31b26e1a8216451f62a14.zip
linhes_pkgbuild-f45fec4bab0e4922c6e31b26e1a8216451f62a14.tar.gz
linhes_pkgbuild-f45fec4bab0e4922c6e31b26e1a8216451f62a14.tar.bz2
perl-sub-name: initial
Diffstat (limited to 'abs/core/perl_modules')
-rw-r--r--abs/core/perl_modules/perl-sub-name/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core/perl_modules/perl-sub-name/PKGBUILD b/abs/core/perl_modules/perl-sub-name/PKGBUILD
new file mode 100644
index 0000000..c671f5b
--- /dev/null
+++ b/abs/core/perl_modules/perl-sub-name/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Contributor: Justin Davis <jrcd83@gmail.com>
+
+pkgname=perl-sub-name
+_cpanname=Sub-Name
+pkgver=0.21
+pkgrel=4
+pkgdesc="(re)name a sub"
+arch=('x86_64')
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+options=('!emptydirs')
+url="http://search.cpan.org/dist/$_cpanname"
+source=("http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_cpanname-$pkgver.tar.gz")
+md5sums=('7e7a181e30b3249d0b81585f55e36621')
+
+build() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}