summaryrefslogtreecommitdiffstats
path: root/abs/core/php
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/php
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/php')
-rw-r--r--abs/core/php/PKGBUILD14
-rw-r--r--abs/core/php/__changelog2
-rw-r--r--abs/core/php/php.ini2
3 files changed, 16 insertions, 2 deletions
diff --git a/abs/core/php/PKGBUILD b/abs/core/php/PKGBUILD
index 975716a..9e297f0 100644
--- a/abs/core/php/PKGBUILD
+++ b/abs/core/php/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=php
pkgver=5.2.6
-pkgrel=23
+pkgrel=31
_suhosinver=0.9.6.2
pkgdesc='A high-level scripting language'
arch=('i686' 'x86_64')
@@ -174,3 +174,15 @@ build() {
# install -D -m644 libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so || return 1
# install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf || return 1
}
+
+
+md5sums=('7380ffecebd95c6edb317ef861229ebd'
+ 'f2ec986341a314c271259dbe4d940858'
+ '0ba86d39163d577c195d57c9129149cd'
+ '96ca078be6729b665be8a865535a97bf'
+ '74e5ce5a02488ec91b1c59f539e42936')
+md5sums=('7380ffecebd95c6edb317ef861229ebd'
+ 'f2ec986341a314c271259dbe4d940858'
+ '13795526fe1a5da17c0aa46d5ea1a5d8'
+ '96ca078be6729b665be8a865535a97bf'
+ '74e5ce5a02488ec91b1c59f539e42936')
diff --git a/abs/core/php/__changelog b/abs/core/php/__changelog
index aac14ba..375545c 100644
--- a/abs/core/php/__changelog
+++ b/abs/core/php/__changelog
@@ -4,3 +4,5 @@ added /data/srv/tmp to basedir
added /usr/share/mythtv/mythweather/scripts/
send errors to stderr
change .install file, timezone is modified on install
+php.ini -jm
+ remove open_basedir
diff --git a/abs/core/php/php.ini b/abs/core/php/php.ini
index 8cbcd56..0d3a568 100644
--- a/abs/core/php/php.ini
+++ b/abs/core/php/php.ini
@@ -249,7 +249,7 @@ safe_mode_protected_env_vars = LD_LIBRARY_PATH
; and below. This directive makes most sense if used in a per-directory
; or per-virtualhost web server configuration file. This directive is
; *NOT* affected by whether Safe Mode is turned On or Off.
-open_basedir = /data/srv/httpd/htdocs/:/home/:/tmp/:/usr/share/pear/:/data/srv/tmp:/usr/share/mythtv/mythweather/scripts/:/data/srv/httpd/htdocs/mythweb/data/video:/myth/ipodfeed:/data/srv/httpd/htdocs/archive:/etc
+;open_basedir = /data/srv/httpd/htdocs/:/home/:/tmp/:/usr/share/pear/:/data/srv/tmp:/usr/share/mythtv/mythweather/scripts/:/data/srv/httpd/htdocs/mythweb/data/video:/myth/ipodfeed:/data/srv/httpd/htdocs/archive:/etc:/myth:/media
; This directive allows you to disable certain functions for security reasons.
; It receives a comma-delimited list of function names. This directive is