summaryrefslogtreecommitdiffstats
path: root/abs/core/plymouth
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-12-04 18:04:47 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-12-04 18:04:47 (GMT)
commit64a523b563e3cd7bb2a640c23267f2cf91d3bacc (patch)
tree437ed9a2d61f559260d72246a2127e50fb8c164b /abs/core/plymouth
parentd5370e5d6fe083e14866c5b5d1728fea4f9879bc (diff)
downloadlinhes_pkgbuild-64a523b563e3cd7bb2a640c23267f2cf91d3bacc.zip
linhes_pkgbuild-64a523b563e3cd7bb2a640c23267f2cf91d3bacc.tar.gz
linhes_pkgbuild-64a523b563e3cd7bb2a640c23267f2cf91d3bacc.tar.bz2
plymouth, plymouth-theme-linhes: update and kill some bugs
LinHES-config: change splash detection
Diffstat (limited to 'abs/core/plymouth')
-rw-r--r--abs/core/plymouth/PKGBUILD149
-rw-r--r--abs/core/plymouth/__changelog4
-rw-r--r--abs/core/plymouth/arch-logo.pngbin11047 -> 46233 bytes
-rw-r--r--abs/core/plymouth/encrypt_hook (renamed from abs/core/plymouth/plymouth-encrypt.hook)20
-rw-r--r--abs/core/plymouth/encrypt_install (renamed from abs/core/plymouth/plymouth-encrypt.install)5
-rw-r--r--abs/core/plymouth/gdm-plymouth.service13
-rw-r--r--abs/core/plymouth/kdm-plymouth.service13
-rw-r--r--abs/core/plymouth/kdm-unpatched-plymouth.service15
-rw-r--r--abs/core/plymouth/lightdm-plymouth.service14
-rw-r--r--abs/core/plymouth/lxdm-plymouth.service13
-rw-r--r--abs/core/plymouth/plymouth-quit.service9
-rw-r--r--abs/core/plymouth/plymouth-set-default-theme.in.patch14
-rw-r--r--abs/core/plymouth/plymouth-update-initrd.patch8
-rw-r--r--abs/core/plymouth/plymouth.functions65
-rw-r--r--abs/core/plymouth/plymouth.hook4
-rw-r--r--abs/core/plymouth/plymouth.initcpio_hook16
-rw-r--r--abs/core/plymouth/plymouth.initcpio_install58
-rw-r--r--abs/core/plymouth/plymouth.install89
-rw-r--r--abs/core/plymouth/plymouthd.conf3
-rw-r--r--abs/core/plymouth/slim-plymouth.service13
-rw-r--r--abs/core/plymouth/system-release1
21 files changed, 412 insertions, 114 deletions
diff --git a/abs/core/plymouth/PKGBUILD b/abs/core/plymouth/PKGBUILD
index a9d1bde..d0849c7 100644
--- a/abs/core/plymouth/PKGBUILD
+++ b/abs/core/plymouth/PKGBUILD
@@ -1,73 +1,118 @@
pkgname=plymouth
pkgver=0.8.8.52.g37d2e40
pkgrel=1
-pkgdesc="A graphical boot splash screen with kernel mode-setting support (Git verson for now)"
+pkgdesc="A graphical boot splash screen with kernel mode-setting support (Git version)"
url="http://cgit.freedesktop.org/cgit/plymouth/"
-
arch=('i686' 'x86_64')
license=('GPL')
-
-depends=('libdrm' 'pango')
+depends=('libdrm' 'pango' 'v86d')
makedepends=('git' 'docbook-xsl')
optdepends=('ttf-dejavu')
-backup=('etc/plymouth/plymouthd.conf')
-options=('!emptydirs')
-conflicts=('plymouth-git')
+options=('!libtool' '!emptydirs')
+install=$pkgname.install
-source=(
-'git://anongit.freedesktop.org/plymouth'
-'plymouth.hook'
-'plymouth.install'
-'plymouth-encrypt.hook'
-'plymouth-encrypt.install'
-'arch-logo.png'
-)
+provides=('plymouth')
+conflicts=('plymouth')
+backup=('etc/plymouth/plymouthd.conf')
-md5sums=(
-'SKIP'
-'SKIP'
-'SKIP'
-'SKIP'
-'SKIP'
-'SKIP'
-)
+source=('git://anongit.freedesktop.org/plymouth'
+ 'arch-logo.png'
+ 'encrypt_hook'
+ 'encrypt_install'
+ 'gdm-plymouth.service'
+ 'kdm-plymouth.service'
+ 'kdm-unpatched-plymouth.service'
+ 'lxdm-plymouth.service'
+ 'lightdm-plymouth.service'
+ 'slim-plymouth.service'
+ 'plymouth.functions'
+ "$pkgname.install"
+ 'plymouth.initcpio_hook'
+ 'plymouth.initcpio_install'
+ 'plymouth-quit.service'
+ 'plymouth-set-default-theme.in.patch'
+ 'plymouth-update-initrd.patch'
+ 'plymouthd.conf'
+ 'system-release')
+
pkgver() {
- cd "$srcdir"/plymouth
- git describe --always | sed 's/-/./g'
+ cd "$srcdir"/${pkgname%%-*}
+ git describe --always | sed 's/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"/${pkgname%%-*}
+
+ patch -Np0 -i ../plymouth-set-default-theme.in.patch
+ patch -Np0 -i ../plymouth-update-initrd.patch
+
+ sed -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:g' \
+ -i src/libply-splash-graphics/ply-image.c
+
+ test -f Makefile && make distclean
+
+ return 0
}
build() {
- cd "$srcdir"/plymouth
- ./autogen.sh --prefix=/usr \
- --exec-prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --sbindir=/usr/bin \
- --enable-drm-renderer \
- --enable-pango \
- --with-logo=/usr/share/plymouth/arch-logo.png \
- --with-boot-tty=/dev/tty7 \
- --with-shutdown-tty=/dev/tty7 \
- --without-system-root-install
- make
+ cd "$srcdir"/${pkgname%%-*}
+
+ ./autogen.sh --prefix=/usr \
+ --exec-prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --sbindir=/usr/bin \
+ --enable-drm-renderer \
+ --enable-tracing \
+ --enable-pango \
+ --with-gdm-autostart-file=yes \
+ --with-logo=/usr/share/plymouth/arch-logo.png \
+ --with-background-start-color-stop=0x000000 \
+ --with-background-end-color-stop=0x4D4D4D \
+ --without-rhgb-compat-link \
+ --without-system-root-install
+
+ make
}
package() {
- cd "$srcdir"/plymouth
- make DESTDIR="$pkgdir" install
+ cd "$srcdir"/${pkgname%%-*}
- # logo
- install -Dm644 "$srcdir"/arch-logo.png "$pkgdir/usr/share/plymouth/arch-logo.png"
+ make DESTDIR="$pkgdir" install
- # remove non-arch script
- rm "$pkgdir/usr/lib/plymouth/"*-initrd
- rm "$pkgdir/usr/bin/plymouth-set-default-theme"
+ install -Dm644 "$srcdir/arch-logo.png" "$pkgdir/usr/share/plymouth/arch-logo.png"
+ install -Dm644 "$srcdir/encrypt_hook" "$pkgdir/usr/lib/initcpio/hooks/plymouth-encrypt"
+ install -Dm644 "$srcdir/encrypt_install" "$pkgdir/usr/lib/initcpio/install/plymouth-encrypt"
+ install -Dm644 "$srcdir/plymouth.functions" "$pkgdir/etc/rc.d/functions.d/plymouth.functions"
+ install -Dm644 "$srcdir/plymouth.initcpio_hook" "$pkgdir/usr/lib/initcpio/hooks/plymouth"
+ install -Dm644 "$srcdir/plymouth.initcpio_install" "$pkgdir/usr/lib/initcpio/install/plymouth"
+ install -Dm644 "$srcdir/plymouthd.conf" "$pkgdir/etc/plymouth/plymouthd.conf"
+ install -Dm644 "$srcdir/system-release" "$pkgdir/etc/system-release"
- # initcpio
- install -Dm644 "$srcdir/plymouth.hook" "$pkgdir/usr/lib/initcpio/hooks/plymouth"
- install -Dm644 "$srcdir/plymouth.install" "$pkgdir/usr/lib/initcpio/install/plymouth"
- install -Dm644 "$srcdir/plymouth-encrypt.hook" "$pkgdir/usr/lib/initcpio/hooks/plymouth-encrypt"
- install -Dm644 "$srcdir/plymouth-encrypt.install" "$pkgdir/usr/lib/initcpio/install/plymouth-encrypt"
+ # Plymouth<->systemd integration, including units for DMs
+ for i in {{gdm,kdm{,-unpatched},lxdm,slim,lightdm}-plymouth,plymouth-quit}.service; do
+ install -Dm644 "$srcdir/$i" "$pkgdir/usr/lib/systemd/system/$i"
+ done
+
}
+md5sums=('SKIP'
+ '65fa2763d5c9bb9f80973ea5e6e3db3e'
+ '79613b70a0a0be4c33978ef37c30f00a'
+ '65eb269910f1b81e3f0970af456394ca'
+ '34d0ed7bbcb3d0ea498de24bc17b2ee9'
+ '75ec0ac73eb9a1e3f6104df64520d431'
+ 'ceec65ce58accdb270f3eaa23d794b4a'
+ '62c3b4e894330a2ca4c2b8fbcaba083c'
+ 'e6d573b1913f3aa020cbde3863ee80f0'
+ '225b953976e1c824f62ba406a63c18c7'
+ 'f0110fba1e77cd22c32d1727399d0b8a'
+ '95e987cfbc2d30a2cea215394eb9ac20'
+ '4f3be343eea9956bbc94d615d5f41def'
+ '7f21ba9a85733ff945c23012cff55a89'
+ '3bb0b8008edfad9e23703674341766a0'
+ '42fddd683720dbacbe6e30b4b7892f3c'
+ '412a1a89ca960370071746b0af8c0ac5'
+ '37479b134827dc307b3c55bfb2711e99'
+ 'ab8a557d10f74bec5c94ed6cae34729c')
diff --git a/abs/core/plymouth/__changelog b/abs/core/plymouth/__changelog
index 21edf18..6b8e8c1 100644
--- a/abs/core/plymouth/__changelog
+++ b/abs/core/plymouth/__changelog
@@ -1,2 +1,4 @@
+pulled from AUR plymouth-git 12/3/13
removed systemd as a dep
-
+removed --enable-systemd configure option
+add v86d as dep
diff --git a/abs/core/plymouth/arch-logo.png b/abs/core/plymouth/arch-logo.png
index e5f4055..9f8446b 100644
--- a/abs/core/plymouth/arch-logo.png
+++ b/abs/core/plymouth/arch-logo.png
Binary files differ
diff --git a/abs/core/plymouth/plymouth-encrypt.hook b/abs/core/plymouth/encrypt_hook
index 7069eff..a3dcda1 100644
--- a/abs/core/plymouth/plymouth-encrypt.hook
+++ b/abs/core/plymouth/encrypt_hook
@@ -1,4 +1,4 @@
-#!/usr/bin/ash
+#!/bin/bash
run_hook() {
modprobe -a -q dm-crypt >/dev/null 2>&1
@@ -66,7 +66,7 @@ EOF
dopassphrase=1
# If keyfile exists, try to use that
if [ -f ${ckeyfile} ]; then
- if eval cryptsetup --key-file ${ckeyfile} open --type luks ${resolved} ${cryptname} ${cryptargs} ${CSQUIET}; then
+ if eval cryptsetup --key-file ${ckeyfile} luksOpen ${resolved} ${cryptname} ${cryptargs} ${CSQUIET}; then
dopassphrase=0
else
echo "Invalid keyfile. Reverting to passphrase."
@@ -74,16 +74,10 @@ EOF
fi
# Ask for a passphrase
if [ ${dopassphrase} -gt 0 ]; then
- echo ""
+ echo
echo "A password is required to access the ${cryptname} volume:"
-
-###
- plymouth ask-for-password \
- --prompt="Password for ${cryptname} volume" \
- --dont-pause-progress \
- --number-of-tries=3 \
- --command="cryptsetup open --type luks ${resolved} ${cryptname} ${cryptargs} ${CSQUIET}"
-###
+ plymouth ask-for-password --prompt="Password for ${cryptname} volume" --dont-pause-progress --number-of-tries=5 --command="/sbin/cryptsetup luksOpen --key-file=- ${cryptdev} ${cryptname} ${CSQUIET}"
+ sleep 2
fi
if [ -e "/dev/mapper/${cryptname}" ]; then
if [ ${DEPRECATED_CRYPT} -eq 1 ]; then
@@ -101,7 +95,7 @@ EOF
err "Non-LUKS decryption not attempted..."
return 1
fi
- exe="cryptsetup open --type plain $resolved $cryptname $cryptargs"
+ exe="cryptsetup create $cryptname $resolved $cryptargs"
IFS=: read c_hash c_cipher c_keysize c_offset c_skip <<EOF
$crypto
EOF
@@ -138,5 +132,3 @@ EOF
fi
rm -f ${ckeyfile}
}
-
-# vim: set ft=sh ts=4 sw=4 et:
diff --git a/abs/core/plymouth/plymouth-encrypt.install b/abs/core/plymouth/encrypt_install
index 0ee8512..5258a0b 100644
--- a/abs/core/plymouth/plymouth-encrypt.install
+++ b/abs/core/plymouth/encrypt_install
@@ -18,12 +18,11 @@ build() {
add_file "/usr/lib/udev/rules.d/13-dm-disk.rules"
add_file "/usr/lib/udev/rules.d/95-dm-notify.rules"
add_file "/usr/lib/initcpio/udev/11-dm-initramfs.rules" "/usr/lib/udev/rules.d/11-dm-initramfs.rules"
-
-###
+ add_binary "/usr/lib/plymouth/label.so"
+ add_binary "/usr/lib/plymouth/text.so"
add_file "/usr/share/fonts/TTF/DejaVuSans.ttf"
add_file "/etc/fonts/fonts.conf"
add_file "/etc/fonts/conf.d/60-latin.conf"
-###
add_runscript
}
diff --git a/abs/core/plymouth/gdm-plymouth.service b/abs/core/plymouth/gdm-plymouth.service
new file mode 100644
index 0000000..d58c0e9
--- /dev/null
+++ b/abs/core/plymouth/gdm-plymouth.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=GNOME Display Manager
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
+
+[Service]
+ExecStart=/usr/sbin/gdm -nodaemon
+StandardOutput=syslog
+
+[Install]
+Alias=display-manager.service
diff --git a/abs/core/plymouth/kdm-plymouth.service b/abs/core/plymouth/kdm-plymouth.service
new file mode 100644
index 0000000..a9e9142
--- /dev/null
+++ b/abs/core/plymouth/kdm-plymouth.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=K Display Manager
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
+
+[Service]
+ExecStart=/usr/bin/kdm -nodaemon
+StandardOutput=syslog
+
+[Install]
+Alias=display-manager.service
diff --git a/abs/core/plymouth/kdm-unpatched-plymouth.service b/abs/core/plymouth/kdm-unpatched-plymouth.service
new file mode 100644
index 0000000..8a4c41d
--- /dev/null
+++ b/abs/core/plymouth/kdm-unpatched-plymouth.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=K Display Manager
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
+
+[Service]
+ExecStartPre=-/usr/bin/plymouth deactivate
+ExecStartPre=-/usr/bin/plymouth quit --retain-splash
+ExecStart=/usr/bin/kdm -nodaemon
+StandardOutput=syslog
+
+[Install]
+Alias=display-manager.service
diff --git a/abs/core/plymouth/lightdm-plymouth.service b/abs/core/plymouth/lightdm-plymouth.service
new file mode 100644
index 0000000..47ec47e
--- /dev/null
+++ b/abs/core/plymouth/lightdm-plymouth.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=LightDM Display Manager
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
+
+[Service]
+ExecStart=/usr/sbin/lightdm
+StandardOutput=syslog
+
+[Install]
+WantedBy=graphical.target
+Alias=display-manager.service
diff --git a/abs/core/plymouth/lxdm-plymouth.service b/abs/core/plymouth/lxdm-plymouth.service
new file mode 100644
index 0000000..dc6b000
--- /dev/null
+++ b/abs/core/plymouth/lxdm-plymouth.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=LXDE Display Manager
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
+
+[Service]
+ExecStart=/usr/sbin/lxdm >/dev/null 2>&1 </dev/null
+StandardOutput=syslog
+
+[Install]
+Alias=display-manager.service
diff --git a/abs/core/plymouth/plymouth-quit.service b/abs/core/plymouth/plymouth-quit.service
new file mode 100644
index 0000000..9d16a27
--- /dev/null
+++ b/abs/core/plymouth/plymouth-quit.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Terminate Plymouth Boot Screen
+After=rc-local.service plymouth-start.service systemd-user-sessions.service
+Before=getty@tty1.service
+
+[Service]
+ExecStart=-/usr/bin/plymouth quit
+Type=oneshot
+TimeoutSec=20 \ No newline at end of file
diff --git a/abs/core/plymouth/plymouth-set-default-theme.in.patch b/abs/core/plymouth/plymouth-set-default-theme.in.patch
new file mode 100644
index 0000000..21f975d
--- /dev/null
+++ b/abs/core/plymouth/plymouth-set-default-theme.in.patch
@@ -0,0 +1,14 @@
+--- scripts/plymouth-set-default-theme.ina 2012-07-15 12:16:53.083156390 +0300
++++ scripts/plymouth-set-default-theme.in 2012-07-15 12:17:32.715893173 +0300
+@@ -173,7 +173,10 @@
+ exit $?
+ fi
+
+-if [ ! -e ${PLYMOUTH_DATADIR}/plymouth/themes/${THEME_NAME}/${THEME_NAME}.plymouth ]; then
++if [ -z ${THEME_NAME} ]; then
++ echo "Please specify a theme name"
++ exit 1
++elif [ ! -e ${PLYMOUTH_DATADIR}/plymouth/themes/${THEME_NAME}/${THEME_NAME}.plymouth ]; then
+ echo "${PLYMOUTH_DATADIR}/plymouth/themes/${THEME_NAME}/${THEME_NAME}.plymouth does not exist" > /dev/stderr
+ exit 1
+ fi
diff --git a/abs/core/plymouth/plymouth-update-initrd.patch b/abs/core/plymouth/plymouth-update-initrd.patch
new file mode 100644
index 0000000..c307199
--- /dev/null
+++ b/abs/core/plymouth/plymouth-update-initrd.patch
@@ -0,0 +1,8 @@
+--- scripts/plymouth-update-initrd.old 2013-10-27 17:02:15.200368142 +0900
++++ scripts/plymouth-update-initrd 2013-10-27 17:02:57.686768138 +0900
+@@ -1,2 +1,4 @@
+#!/bin/bash
+-dracut -f /boot/initramfs-$(uname -r).img $(uname -r)
++find /etc/mkinitcpio.d/ -name \*.preset -a \! -name example.preset | while read p; do
++ mkinitcpio -p $p
++done
diff --git a/abs/core/plymouth/plymouth.functions b/abs/core/plymouth/plymouth.functions
new file mode 100644
index 0000000..b866643
--- /dev/null
+++ b/abs/core/plymouth/plymouth.functions
@@ -0,0 +1,65 @@
+if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
+
+ ply_client() { /usr/bin/plymouth --ping && /usr/bin/plymouth "$@"; }
+ ply_daemon() { /usr/sbin/plymouthd "$@"; }
+
+ # save a function under a new name
+ save_function() {
+ local ORIG=$(declare -f $1)
+ eval "$2${ORIG#$1}"
+ }
+
+ save_function stat_busy std_stat_busy
+ save_function stat_fail std_stat_fail
+
+ # overwrite status functions
+ stat_busy() {
+ ply_client --update="$1"
+ ply_client message --text="$1"
+ std_stat_busy "$@"
+ }
+
+ stat_fail() {
+ ply_client --quit
+ std_stat_fail "$@"
+ }
+
+ # update after local filesystems are mounted
+ ply_sysinit_postmount() { ply_client --sysinit; }
+ add_hook sysinit_postmount ply_sysinit_postmount
+
+ # stop plymouth after rc.multi
+ ply_quit_boot() {
+ ply_client quit --retain-splash
+ }
+ add_hook multi_end ply_quit_boot
+
+ # stop plymouth before shutdown
+ ply_quit_shutdown() {
+ ply_quit_boot
+ [[ $(ps h $(cat /tmp/plymouthd)) ]] && kill -9 $(cat /tmp/plymouthd)
+ }
+ add_hook shutdown_poweroff ply_quit_shutdown
+
+ # start plymouth at the beginning of rc.shutdown
+ ply_shutdown_start(){
+ XPID=`pidof X`
+ if [ "$XPID" ]; then
+ if [ "`runlevel | cut -c 3`" != '5' ]; then
+ local DM
+ for DM in slim gdm kdm xdm entrance; do
+ ck_daemon "$DM" || stop_daemon "$DM"
+ done
+ fi
+ kill -9 $XPID &> /dev/null
+ fi
+ ply_daemon --mode=shutdown --pid-file=/tmp/plymouthd
+ ply_client --show-splash
+
+ # don't get killed by kill_all
+ add_omit_pids `cat /tmp/plymouthd`
+ }
+ add_hook shutdown_start ply_shutdown_start
+
+fi
+# vim: set ts=2 sw=2 ft=sh noet:
diff --git a/abs/core/plymouth/plymouth.hook b/abs/core/plymouth/plymouth.hook
deleted file mode 100644
index 36a5e1b..0000000
--- a/abs/core/plymouth/plymouth.hook
+++ /dev/null
@@ -1,4 +0,0 @@
-run_hook() {
- /usr/bin/plymouthd --mode=boot
- /usr/bin/plymouth --show-splash
-}
diff --git a/abs/core/plymouth/plymouth.initcpio_hook b/abs/core/plymouth/plymouth.initcpio_hook
new file mode 100644
index 0000000..d527f24
--- /dev/null
+++ b/abs/core/plymouth/plymouth.initcpio_hook
@@ -0,0 +1,16 @@
+run_hook() {
+ msg -n ":: Loading plymouth..."
+
+ /bin/mknod /dev/fb c 29 0 &>/dev/null
+ #/bin/mount devpts /dev/pts -t devpts
+
+ # plymouth deamon
+ #/bin/mkdir -p /run/plymouth
+ /usr/sbin/plymouthd --mode=boot --pid-file=/run/plymouth.pid
+
+ # plymouth frontend
+ /usr/bin/plymouth --show-splash
+ msg "done."
+}
+
+# vim: set ft=sh:
diff --git a/abs/core/plymouth/plymouth.initcpio_install b/abs/core/plymouth/plymouth.initcpio_install
new file mode 100644
index 0000000..22cc298
--- /dev/null
+++ b/abs/core/plymouth/plymouth.initcpio_install
@@ -0,0 +1,58 @@
+build() {
+ add_dir /dev/pts
+ add_dir /usr/share/plymouth/themes
+
+ DATADIR="/usr/share"
+ PLYMOUTH_LOGO_FILE="${DATADIR}/plymouth/arch-logo.png"
+ PLYMOUTH_THEME_NAME="$(/usr/bin/plymouth-set-default-theme)"
+ PLYMOUTH_MODULE_NAME="$(grep "ModuleName *= *" ${DATADIR}/plymouth/themes/${PLYMOUTH_THEME_NAME}/${PLYMOUTH_THEME_NAME}.plymouth | sed 's/ModuleName *= *//')"
+ PLYMOUTH_PLUGIN_PATH="$(plymouth --get-splash-plugin-path)"
+
+ add_binary /usr/bin/plymouthd
+ add_binary /usr/bin/plymouth
+
+ add_file ${DATADIR}/plymouth/themes/text/text.plymouth
+ add_binary ${PLYMOUTH_PLUGIN_PATH}/text.so
+ add_file ${DATADIR}/plymouth/themes/details/details.plymouth
+ add_binary ${PLYMOUTH_PLUGIN_PATH}/details.so
+
+
+ add_file "${PLYMOUTH_LOGO_FILE}"
+ add_file /etc/system-release /etc/system-release
+ add_file /etc/plymouth/plymouthd.conf
+ add_file ${DATADIR}/plymouth/plymouthd.defaults
+
+ if [ ! -f ${PLYMOUTH_PLUGIN_PATH}/${PLYMOUTH_MODULE_NAME}.so ]; then
+ echo "The default plymouth plugin (${PLYMOUTH_MODULE_NAME}) doesn't exist" > /dev/stderr
+ exit 1
+ fi
+
+ add_binary ${PLYMOUTH_PLUGIN_PATH}/${PLYMOUTH_MODULE_NAME}.so
+
+ add_binary ${PLYMOUTH_PLUGIN_PATH}/renderers/drm.so
+ #add_binary ${PLYMOUTH_PLUGIN_PATH}/renderers/x11.so
+ add_binary ${PLYMOUTH_PLUGIN_PATH}/renderers/frame-buffer.so
+
+ if [ -d ${DATADIR}/plymouth/themes/${PLYMOUTH_THEME_NAME} ]; then
+ for x in ${DATADIR}/plymouth/themes/${PLYMOUTH_THEME_NAME}/* ; do
+ [ ! -f "$x" ] && break
+ add_file $x
+ done
+ fi
+
+ # suppress a warning in glib (which the label control uses)
+ # about uid 0 by building a dummy NSS stack (LP #649917)
+ add_file /etc/passwd
+ add_file /etc/nsswitch.conf
+ add_binary "$(readlink -e /lib/libnss_files.so.2)"
+ add_file /lib/libnss_files.so.2
+
+ add_runscript
+}
+
+help() {
+ echo "This hook includes plymouth in the initramfs image."
+}
+
+# vim: set ft=sh:
+#EOF
diff --git a/abs/core/plymouth/plymouth.install b/abs/core/plymouth/plymouth.install
index 9194805..99aa7ee 100644
--- a/abs/core/plymouth/plymouth.install
+++ b/abs/core/plymouth/plymouth.install
@@ -1,43 +1,52 @@
-build() {
- theme="$(get_theme "/etc/plymouth/plymouthd.conf")"
- if [[ "$theme" ]]; then
- add_file /etc/plymouth/plymouthd.conf
- else
- # fallback
- theme="$(get_theme "/usr/share/plymouth/plymouthd.defaults")"
- if [[ ! "$theme" ]]; then
- echo "no theme set for plymouth"
- exit 1
- fi
- add_file /usr/share/plymouth/plymouthd.defaults
- fi
-
- if [[ ! -d "/usr/share/plymouth/themes/$theme" ]]; then
- echo "invalid plymouth theme: $theme"
- exit 1
- fi
-
- module="$(get_module "$theme")"
- add_file /usr/share/plymouth/arch-logo.png
-
- add_binary /usr/bin/plymouthd
- add_binary /usr/bin/plymouth
-
- add_binary /usr/lib/plymouth/renderers/drm.so
- add_binary /usr/lib/plymouth/renderers/frame-buffer.so
-
- add_binary /usr/lib/plymouth/$module.so
- add_full_dir /usr/share/plymouth/themes/$theme
-
- add_runscript
+post_install() {
+cat <<EOF
+
+===========
+
+1. To make Plymouth work:
+ 1.1. Add "plymouth" to HOOKS after "base" and "udev" in /etc/mkinitcpio.conf
+ 1.2. Add 'quiet splash' to the grub command line
+ 1.3. Rebuild your initrd image (# mkinitcpio -p [kernel preset name]).
+ E.g.: sudo mkinitcpio -p linux
+
+===========
+
+2. To enable encryption, replace "encrypt" with "plymouth-encrypt" in
+ mkinitcpio.conf and rebuild your initrd image.
+
+===========
+
+3. You will also need to rebuild your initrd image every time you change your
+ theme (the default is set as 'spinfinity').
+
+ To list all plymouth themes:
+ plymouth-set-default-theme -l
+
+ To change theme and rebuild initrd image:
+ # plymouth-set-default-theme -R <theme>
+
+===========
+
+4. For Smooth Transition to Display Manager you have to:
+ 4.1. See the Wiki Page (link in 5) to prepare your Display Manager
+ 4.2. Disable your Display Manager Unit
+ E.g. : # systemctl disable kdm.service
+ 4.3. Enable the respective DM-plymouth Unit (GDM, KDM, LXDM units provided)
+ E.g. : # systemctl enable kdm-plymouth.service
+
+===========
+
+5. For more information please visit the Wiki page:
+ https://wiki.archlinux.org/index.php/Plymouth
+
+===========
+
+OBS. If you have any leftover "kill Plymouth" lines in /etc/rc.local or
+~/.xinitrc they are no longer required.
+
+EOF
}
-# $1 = file
-get_theme() {
- grep ^Theme= "$1" | cut -d = -f 2-
-}
-
-# $1 = theme
-get_module() {
- grep ^ModuleName= "/usr/share/plymouth/themes/$1/$1.plymouth" | cut -d = -f 2-
+post_upgrade() {
+ post_install
}
diff --git a/abs/core/plymouth/plymouthd.conf b/abs/core/plymouth/plymouthd.conf
new file mode 100644
index 0000000..50de7f8
--- /dev/null
+++ b/abs/core/plymouth/plymouthd.conf
@@ -0,0 +1,3 @@
+# Administrator customizations go in this file
+[Daemon]
+Theme=spinfinity
diff --git a/abs/core/plymouth/slim-plymouth.service b/abs/core/plymouth/slim-plymouth.service
new file mode 100644
index 0000000..8806c7d
--- /dev/null
+++ b/abs/core/plymouth/slim-plymouth.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=SLiM Simple Login Manager
+After=systemd-user-sessions.service
+
+Conflicts=plymouth-quit.service
+After=plymouth-quit.service
+
+[Service]
+ExecStart=/usr/bin/slim -nodaemon
+StandardOutput=syslog
+
+[Install]
+Alias=display-manager.service
diff --git a/abs/core/plymouth/system-release b/abs/core/plymouth/system-release
new file mode 100644
index 0000000..850183e
--- /dev/null
+++ b/abs/core/plymouth/system-release
@@ -0,0 +1 @@
+Arch Linux