summaryrefslogtreecommitdiffstats
path: root/abs/core/plymouth
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-09 23:57:22 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-09 23:57:22 (GMT)
commit7b7804b4e5f46623794208d5dbcfe43c57a7e7a4 (patch)
tree465124768864f5971983f9f1b43a677ef1b31bd4 /abs/core/plymouth
parent53a9bfc6166ef4181ddc5797c6b3a0c441887585 (diff)
downloadlinhes_pkgbuild-7b7804b4e5f46623794208d5dbcfe43c57a7e7a4.zip
linhes_pkgbuild-7b7804b4e5f46623794208d5dbcfe43c57a7e7a4.tar.gz
linhes_pkgbuild-7b7804b4e5f46623794208d5dbcfe43c57a7e7a4.tar.bz2
plymouth: shutdown stalls when plymouth is running during shutdown. The short term solution is to run plymouth only on startup and don't restart on shutdown.
refs #871
Diffstat (limited to 'abs/core/plymouth')
-rw-r--r--abs/core/plymouth/PKGBUILD4
-rw-r--r--abs/core/plymouth/plymouth.functions9
2 files changed, 8 insertions, 5 deletions
diff --git a/abs/core/plymouth/PKGBUILD b/abs/core/plymouth/PKGBUILD
index 599e6a8..34c40c5 100644
--- a/abs/core/plymouth/PKGBUILD
+++ b/abs/core/plymouth/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=plymouth
pkgver=0.8.8
-pkgrel=2
+pkgrel=3
pkgdesc="A graphical boot splash screen with kernel mode-setting support"
arch=('i686' 'x86_64')
url="http://freedesktop.org/wiki/Software/Plymouth"
@@ -117,7 +117,7 @@ md5sums=('38f5e613e5ab17806b950cee2d0d0d4e'
'ceec65ce58accdb270f3eaa23d794b4a'
'e6d573b1913f3aa020cbde3863ee80f0'
'62c3b4e894330a2ca4c2b8fbcaba083c'
- 'f0110fba1e77cd22c32d1727399d0b8a'
+ 'a1763999bc3282771e712765c9427d77'
'4f3be343eea9956bbc94d615d5f41def'
'e606ce14ceace727c2f13758e371a4ed'
'761f5090dc999e50b4572138347c775b'
diff --git a/abs/core/plymouth/plymouth.functions b/abs/core/plymouth/plymouth.functions
index b866643..cfaa19b 100644
--- a/abs/core/plymouth/plymouth.functions
+++ b/abs/core/plymouth/plymouth.functions
@@ -1,3 +1,4 @@
+#!/bin/bash
if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
ply_client() { /usr/bin/plymouth --ping && /usr/bin/plymouth "$@"; }
@@ -20,7 +21,8 @@ if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
}
stat_fail() {
- ply_client --quit
+ #JM remove client quitting
+ #ply_client --quit
std_stat_fail "$@"
}
@@ -39,7 +41,7 @@ if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
ply_quit_boot
[[ $(ps h $(cat /tmp/plymouthd)) ]] && kill -9 $(cat /tmp/plymouthd)
}
- add_hook shutdown_poweroff ply_quit_shutdown
+# JM add_hook shutdown_poweroff ply_quit_shutdown
# start plymouth at the beginning of rc.shutdown
ply_shutdown_start(){
@@ -59,7 +61,8 @@ if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
# don't get killed by kill_all
add_omit_pids `cat /tmp/plymouthd`
}
- add_hook shutdown_start ply_shutdown_start
+#remove shutdown hook so plymouth doesn't start
+#JM add_hook shutdown_start ply_shutdown_start
fi
# vim: set ts=2 sw=2 ft=sh noet: