summaryrefslogtreecommitdiffstats
path: root/abs/core/plymouth
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-01-16 21:03:49 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-01-16 21:03:49 (GMT)
commitbdd7476cc2c261eaa8f80b632f583b35b800a4b2 (patch)
tree4ff49c854828a983214683e802a08c7214630a91 /abs/core/plymouth
parentd715be12b1de1e310f1b53922090c64c534d0fdc (diff)
downloadlinhes_pkgbuild-bdd7476cc2c261eaa8f80b632f583b35b800a4b2.zip
linhes_pkgbuild-bdd7476cc2c261eaa8f80b632f583b35b800a4b2.tar.gz
linhes_pkgbuild-bdd7476cc2c261eaa8f80b632f583b35b800a4b2.tar.bz2
plymouth: run plymouth_config.py --mkinitcpio on install & upgrade
Diffstat (limited to 'abs/core/plymouth')
-rw-r--r--abs/core/plymouth/PKGBUILD10
-rw-r--r--abs/core/plymouth/__changelog3
-rw-r--r--abs/core/plymouth/plymouth.functions2
-rw-r--r--abs/core/plymouth/plymouth.install47
-rw-r--r--abs/core/plymouth/system-release2
5 files changed, 10 insertions, 54 deletions
diff --git a/abs/core/plymouth/PKGBUILD b/abs/core/plymouth/PKGBUILD
index 4aeec1d..6f931ec 100644
--- a/abs/core/plymouth/PKGBUILD
+++ b/abs/core/plymouth/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=plymouth
pkgver=0.8.8.52.g37d2e40
-pkgrel=5
+pkgrel=6
pkgdesc="A graphical boot splash screen with kernel mode-setting support (Git version)"
url="http://cgit.freedesktop.org/cgit/plymouth/"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ depends=('libdrm' 'pango' 'v86d')
makedepends=('git' 'docbook-xsl')
optdepends=('ttf-dejavu')
options=('!libtool' '!emptydirs')
-#install=$pkgname.install
+install=$pkgname.install
groups=('base')
provides=('plymouth')
conflicts=('plymouth')
@@ -107,12 +107,12 @@ md5sums=('SKIP'
'62c3b4e894330a2ca4c2b8fbcaba083c'
'e6d573b1913f3aa020cbde3863ee80f0'
'225b953976e1c824f62ba406a63c18c7'
- 'f0110fba1e77cd22c32d1727399d0b8a'
- '95e987cfbc2d30a2cea215394eb9ac20'
+ '552347553a9a551eae8fb02a7007757e'
+ '00213e9b7e6407d40f37207a53059b74'
'4f3be343eea9956bbc94d615d5f41def'
'7f21ba9a85733ff945c23012cff55a89'
'3bb0b8008edfad9e23703674341766a0'
'42fddd683720dbacbe6e30b4b7892f3c'
'412a1a89ca960370071746b0af8c0ac5'
'37479b134827dc307b3c55bfb2711e99'
- 'ab8a557d10f74bec5c94ed6cae34729c')
+ 'c5ebb2ad172770dee8a375954c23f2eb')
diff --git a/abs/core/plymouth/__changelog b/abs/core/plymouth/__changelog
index b9c41f9..441448d 100644
--- a/abs/core/plymouth/__changelog
+++ b/abs/core/plymouth/__changelog
@@ -2,4 +2,5 @@ pulled from AUR plymouth-git 12/3/13
PKGBUILD: removed systemd as a dep
PKGBUILD: removed --enable-systemd configure option
PKGBUILD: add v86d as dep
-PKGBUILD: comment out install line
+plymouth.install: call plymouth_config.py --mkinitcpio to rebuild image
+plymouth.functions: comments out ply_client --quit on fail message
diff --git a/abs/core/plymouth/plymouth.functions b/abs/core/plymouth/plymouth.functions
index b866643..7b30fe9 100644
--- a/abs/core/plymouth/plymouth.functions
+++ b/abs/core/plymouth/plymouth.functions
@@ -20,7 +20,7 @@ if [[ -x /usr/bin/plymouth && -x /usr/sbin/plymouthd ]]; then
}
stat_fail() {
- ply_client --quit
+ #ply_client --quit
std_stat_fail "$@"
}
diff --git a/abs/core/plymouth/plymouth.install b/abs/core/plymouth/plymouth.install
index 99aa7ee..759786a 100644
--- a/abs/core/plymouth/plymouth.install
+++ b/abs/core/plymouth/plymouth.install
@@ -1,50 +1,5 @@
post_install() {
-cat <<EOF
-
-===========
-
-1. To make Plymouth work:
- 1.1. Add "plymouth" to HOOKS after "base" and "udev" in /etc/mkinitcpio.conf
- 1.2. Add 'quiet splash' to the grub command line
- 1.3. Rebuild your initrd image (# mkinitcpio -p [kernel preset name]).
- E.g.: sudo mkinitcpio -p linux
-
-===========
-
-2. To enable encryption, replace "encrypt" with "plymouth-encrypt" in
- mkinitcpio.conf and rebuild your initrd image.
-
-===========
-
-3. You will also need to rebuild your initrd image every time you change your
- theme (the default is set as 'spinfinity').
-
- To list all plymouth themes:
- plymouth-set-default-theme -l
-
- To change theme and rebuild initrd image:
- # plymouth-set-default-theme -R <theme>
-
-===========
-
-4. For Smooth Transition to Display Manager you have to:
- 4.1. See the Wiki Page (link in 5) to prepare your Display Manager
- 4.2. Disable your Display Manager Unit
- E.g. : # systemctl disable kdm.service
- 4.3. Enable the respective DM-plymouth Unit (GDM, KDM, LXDM units provided)
- E.g. : # systemctl enable kdm-plymouth.service
-
-===========
-
-5. For more information please visit the Wiki page:
- https://wiki.archlinux.org/index.php/Plymouth
-
-===========
-
-OBS. If you have any leftover "kill Plymouth" lines in /etc/rc.local or
-~/.xinitrc they are no longer required.
-
-EOF
+ plymouth_config.py --mkinitcpio
}
post_upgrade() {
diff --git a/abs/core/plymouth/system-release b/abs/core/plymouth/system-release
index 850183e..eec61fb 100644
--- a/abs/core/plymouth/system-release
+++ b/abs/core/plymouth/system-release
@@ -1 +1 @@
-Arch Linux
+LinHES