summaryrefslogtreecommitdiffstats
path: root/abs/core/poweroff-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-01-05 02:34:42 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-01-05 02:34:42 (GMT)
commit18247ddb31727b83ce110a3d05fa16bf117beb51 (patch)
tree1167321224fc3d8a0d409cd4ab82ac16f9182409 /abs/core/poweroff-scripts
parent7a2658fa493edc8b89051ca93e9b4086d0709660 (diff)
downloadlinhes_pkgbuild-18247ddb31727b83ce110a3d05fa16bf117beb51.zip
linhes_pkgbuild-18247ddb31727b83ce110a3d05fa16bf117beb51.tar.gz
linhes_pkgbuild-18247ddb31727b83ce110a3d05fa16bf117beb51.tar.bz2
poweroff-scripts: suppress myth_status when sourcing /etc/profile
Diffstat (limited to 'abs/core/poweroff-scripts')
-rw-r--r--abs/core/poweroff-scripts/PKGBUILD8
-rw-r--r--abs/core/poweroff-scripts/halt.script1
-rw-r--r--abs/core/poweroff-scripts/reboot.script1
-rw-r--r--abs/core/poweroff-scripts/shutdown.script1
4 files changed, 7 insertions, 4 deletions
diff --git a/abs/core/poweroff-scripts/PKGBUILD b/abs/core/poweroff-scripts/PKGBUILD
index f15cddf..9bcfee1 100644
--- a/abs/core/poweroff-scripts/PKGBUILD
+++ b/abs/core/poweroff-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=poweroff-scripts
pkgver=1.1
-pkgrel=2
+pkgrel=3
pkgdesc="replacement scripts to work with sysvinit and runit"
license=('GPL')
depends=('sysvinit>=2.88' 'runit>=2.1.1-6')
@@ -21,7 +21,7 @@ build() {
}
-md5sums=('e84d487ebd5c3cccd3477988efad3080'
- '263198ec006b87891ea0f3ab1d103086'
+md5sums=('68ac5d7d5784e9559c9752d94a4943d5'
+ '3e042113f8715bc5bfd365d2486d0108'
'3ec5f3013dcbd60b6b957d17ba220585'
- '953653da83f5188d51373abf4a42ba05')
+ '16bb393e9ae7b5fa744ca91970f350cc')
diff --git a/abs/core/poweroff-scripts/halt.script b/abs/core/poweroff-scripts/halt.script
index cfc05aa..dacf16a 100644
--- a/abs/core/poweroff-scripts/halt.script
+++ b/abs/core/poweroff-scripts/halt.script
@@ -1,4 +1,5 @@
#!/bin/bash
+MYTH_RUN_STATUS="1"
. /etc/profile
INIT=`ps -p 1 -o comm=`
if [ x$1 = x-w ]
diff --git a/abs/core/poweroff-scripts/reboot.script b/abs/core/poweroff-scripts/reboot.script
index fcce679..47ad99e 100644
--- a/abs/core/poweroff-scripts/reboot.script
+++ b/abs/core/poweroff-scripts/reboot.script
@@ -1,4 +1,5 @@
#!/bin/bash
+MYTH_RUN_STATUS="1"
. /etc/profile
INIT=`ps -p 1 -o comm=`
chvt 1
diff --git a/abs/core/poweroff-scripts/shutdown.script b/abs/core/poweroff-scripts/shutdown.script
index 09245ef..31881e8 100644
--- a/abs/core/poweroff-scripts/shutdown.script
+++ b/abs/core/poweroff-scripts/shutdown.script
@@ -1,4 +1,5 @@
#!/bin/bash
+MYTH_RUN_STATUS="1"
. /etc/profile
INIT=`ps -p 1 -o comm=`
if [ x$INIT = xrunit ]