summaryrefslogtreecommitdiffstats
path: root/abs/core/ppl
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 18:20:20 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 18:20:20 (GMT)
commit897520d66acfb12a070a36845cac37886bbfe644 (patch)
treee2962db075baa3dc11c81568683ad8ef1bc9366a /abs/core/ppl
parentdbffaa2d8cb83d299a5b3c456e9f39a03c76cac0 (diff)
downloadlinhes_pkgbuild-897520d66acfb12a070a36845cac37886bbfe644.zip
linhes_pkgbuild-897520d66acfb12a070a36845cac37886bbfe644.tar.gz
linhes_pkgbuild-897520d66acfb12a070a36845cac37886bbfe644.tar.bz2
ppl 1.0
Diffstat (limited to 'abs/core/ppl')
-rw-r--r--abs/core/ppl/PKGBUILD16
-rw-r--r--abs/core/ppl/ppl-0.10.2-gmp-5.0.patch30
2 files changed, 11 insertions, 35 deletions
diff --git a/abs/core/ppl/PKGBUILD b/abs/core/ppl/PKGBUILD
index ee5979a..daa1196 100644
--- a/abs/core/ppl/PKGBUILD
+++ b/abs/core/ppl/PKGBUILD
@@ -1,23 +1,28 @@
-# $Id: PKGBUILD 87232 2010-08-11 12:07:18Z allan $
+# $Id: PKGBUILD 162899 2012-07-03 10:44:19Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: ezzetabi <ezzetabi at gawab dot com>
pkgname=ppl
-pkgver=0.11
+pkgver=1.0
pkgrel=1
pkgdesc="A modern library for convex polyhedra and other numerical abstractions."
arch=('i686' 'x86_64')
-url="http://www.cs.unipr.it/ppl"
+url="http://bugseng.com/products/ppl"
license=('GPL3')
depends=('gmp>=5.0')
options=('!docs' '!libtool')
-source=(http://www.cs.unipr.it/ppl/Download/ftp/releases/$pkgver/ppl-$pkgver.tar.gz)
-md5sums=('ba527ec0ffc830ce16fad8a4195a337e')
+source=(http://bugseng.com/products/ppl/download/ftp/releases/$pkgver/ppl-$pkgver.tar.gz{,.sign})
+md5sums=('c4566928c6b7bb63e95f96d1a7b5cb4c'
+ '5f490df826c76fed296060ca8fca4eb5')
build() {
cd $srcdir/ppl-$pkgver
./configure --prefix=/usr --enable-interfaces="c,cxx"
make
+}
+
+check() {
+ cd $srcdir/ppl-$pkgver
make check
}
@@ -25,3 +30,4 @@ package() {
cd $srcdir/ppl-$pkgver
make DESTDIR=$pkgdir install
}
+
diff --git a/abs/core/ppl/ppl-0.10.2-gmp-5.0.patch b/abs/core/ppl/ppl-0.10.2-gmp-5.0.patch
deleted file mode 100644
index 4d6964a..0000000
--- a/abs/core/ppl/ppl-0.10.2-gmp-5.0.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/m4/ac_check_gmp.m4 b/m4/ac_check_gmp.m4
-index 60cecdc..15acb18 100644
---- a/m4/ac_check_gmp.m4
-+++ b/m4/ac_check_gmp.m4
-@@ -71,6 +71,10 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([[
- #GMP version 4.1.3 or higher is required
- #endif
-
-+#ifndef BITS_PER_MP_LIMB
-+#define BITS_PER_MP_LIMB GMP_LIMB_BITS
-+#endif
-+
- int
- main() {
- std::string header_version;
-@@ -97,11 +101,11 @@ main() {
- return 1;
- }
-
-- if (sizeof(mp_limb_t)*CHAR_BIT != GMP_LIMB_BITS
-- || GMP_LIMB_BITS != mp_bits_per_limb) {
-+ if (sizeof(mp_limb_t)*CHAR_BIT != BITS_PER_MP_LIMB
-+ || BITS_PER_MP_LIMB != mp_bits_per_limb) {
- std::cerr
- << "GMP header (gmp.h) and library (ligmp.*) bits-per-limb mismatch:\n"
-- << "header gives " << __GMP_BITS_PER_MP_LIMB << ";\n"
-+ << "header gives " << BITS_PER_MP_LIMB << ";\n"
- << "library gives " << mp_bits_per_limb << ".\n"
- << "This probably means you are on a bi-arch system and\n"
- << "you are compiling with the wrong header or linking with\n"