summaryrefslogtreecommitdiffstats
path: root/abs/core/pth
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 18:22:42 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 18:22:42 (GMT)
commit73d694339944ca38fcdc66ca5dc61ead41c218d7 (patch)
tree44a3892e8b4f3e2e4f372cba678b04dd7bc413a4 /abs/core/pth
parent826f655c524b0bf01723cd366fa260ffc47e69be (diff)
downloadlinhes_pkgbuild-73d694339944ca38fcdc66ca5dc61ead41c218d7.zip
linhes_pkgbuild-73d694339944ca38fcdc66ca5dc61ead41c218d7.tar.gz
linhes_pkgbuild-73d694339944ca38fcdc66ca5dc61ead41c218d7.tar.bz2
pth 2.0.7
Diffstat (limited to 'abs/core/pth')
-rw-r--r--abs/core/pth/PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/abs/core/pth/PKGBUILD b/abs/core/pth/PKGBUILD
new file mode 100644
index 0000000..8ba1b84
--- /dev/null
+++ b/abs/core/pth/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id: PKGBUILD 146737 2012-01-16 22:52:42Z dreisner $
+# Maintainer: damir <damir@archlinux.org>
+
+pkgname=pth
+pkgver=2.0.7
+pkgrel=4
+pkgdesc="The GNU Portable Threads."
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/pth/"
+license=('LGPL')
+depends=('glibc' 'awk')
+options=('!libtool' '!makeflags')
+source=(ftp://ftp.gnu.org/gnu/pth/$pkgname-$pkgver.tar.gz{,.sig})
+sha1sums=('9a71915c89ff2414de69fe104ae1016d513afeee'
+ '8cb16dffbf15ba92bda8d08918eaf5995642fc38')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --disable-static \
+ --enable-shared \
+ --with-pic
+
+ sed -i "s|awk=''|awk=/bin/awk|g" shtool # "Cannot find a reasonable Awk"
+
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR=${pkgdir} install
+}