summaryrefslogtreecommitdiffstats
path: root/abs/core/python-decorator/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/python-decorator/PKGBUILD
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/python-decorator/PKGBUILD')
-rw-r--r--abs/core/python-decorator/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/core/python-decorator/PKGBUILD b/abs/core/python-decorator/PKGBUILD
new file mode 100644
index 0000000..a7cd692
--- /dev/null
+++ b/abs/core/python-decorator/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Pierre Chapuis <catwell at archlinux dot us>
+
+pkgname=python-decorator
+pkgver=3.2.0
+pkgrel=1
+pkgdesc='Python Decorator module'
+arch=('any')
+url='http://pypi.python.org/pypi/decorator'
+license=('BSD')
+depends=('python')
+source=("http://pypi.python.org/packages/source/d/decorator/decorator-${pkgver}.tar.gz"
+ 'LICENSE.txt')
+md5sums=('6208cd51365083c168ab3a04426a646b'
+ '0ca76d2c707f09dbb04acc425ea1a08b')
+
+build() {
+ cd decorator-${pkgver}
+
+ python setup.py build
+}
+
+package() {
+ cd decorator-${pkgver}
+
+ python setup.py install --root=${pkgdir} --optimize=1
+
+ install -D -m644 ${srcdir}/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}