summaryrefslogtreecommitdiffstats
path: root/abs/core/python-numeric/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-18 01:56:26 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-18 01:56:26 (GMT)
commit56eb3736255e1d57d9083c353c6af73e6f97a69d (patch)
treeb099a117b26cdf319cb1c63dd297761a545c3a61 /abs/core/python-numeric/PKGBUILD
parentd1f77047874dae53231805117878c25ec240bb43 (diff)
downloadlinhes_pkgbuild-56eb3736255e1d57d9083c353c6af73e6f97a69d.zip
linhes_pkgbuild-56eb3736255e1d57d9083c353c6af73e6f97a69d.tar.gz
linhes_pkgbuild-56eb3736255e1d57d9083c353c6af73e6f97a69d.tar.bz2
python-numeric: update/bump
Diffstat (limited to 'abs/core/python-numeric/PKGBUILD')
-rw-r--r--abs/core/python-numeric/PKGBUILD36
1 files changed, 26 insertions, 10 deletions
diff --git a/abs/core/python-numeric/PKGBUILD b/abs/core/python-numeric/PKGBUILD
index 67a8ab5..7c7f58c 100644
--- a/abs/core/python-numeric/PKGBUILD
+++ b/abs/core/python-numeric/PKGBUILD
@@ -1,19 +1,35 @@
-# $Id: PKGBUILD 16713 2008-10-22 02:37:43Z allan $
-# Maintainer: arjan <arjan@archlinux.org>
+# Maintainer: SpepS <dreamspepser at yahoo dot it>
+# Contributor: arjan <arjan@archlinux.org>
# Contributor orelien <aurelien.foret@wanadoo.fr>
pkgname=python-numeric
pkgver=24.2
-pkgrel=3
-pkgdesc="Numerical Python adds a fast array facility to the Python language."
+pkgrel=5
+pkgdesc="Numerical Python adds a fast array facility to the Python language"
arch=(i686 x86_64)
-depends=('python>=2.5')
-source=(http://downloads.sourceforge.net/sourceforge/numpy/Numeric-${pkgver}.tar.gz)
-replaces=('numeric')
url="http://numeric.scipy.org/"
-md5sums=(2ae672656e06716a149acb048cca3093)
+license=('custom')
+depends=('python2')
+source=(http://downloads.sourceforge.net/sourceforge/numpy/Numeric-$pkgver.tar.gz)
+md5sums=('2ae672656e06716a149acb048cca3093')
build() {
- cd ${startdir}/src/Numeric-${pkgver}
- python setup.py install --root=${startdir}/pkg
+
+ cd "$srcdir/Numeric-$pkgver"
+
+ # Python2 fix
+ sed \
+ -e "s_\(env python\).*_\12_" \
+ -e "s_\(bin/python\).*_\12_" \
+ -i `grep -rlE "(env python|bin/python)" .`
}
+
+package() {
+
+ cd "$srcdir/Numeric-$pkgver"
+
+ # Install
+ python2 setup.py install --prefix=/usr --root="$pkgdir/"
+ install -D -m644 Legal.htm "$pkgdir/usr/share/licenses/$pkgname/Legal.htm"
+}
+