summaryrefslogtreecommitdiffstats
path: root/abs/core/python/python-internal-expat.patch
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-13 02:18:30 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-13 02:18:30 (GMT)
commit13b02bb7a18ddb858e1fb88ef6e762eabd4fcafd (patch)
treedc128249fa7837741a9932b58dd6c13cf63cd732 /abs/core/python/python-internal-expat.patch
parentc3144d6244d7a072ba6c177d056883bdf3cd49bb (diff)
downloadlinhes_pkgbuild-13b02bb7a18ddb858e1fb88ef6e762eabd4fcafd.zip
linhes_pkgbuild-13b02bb7a18ddb858e1fb88ef6e762eabd4fcafd.tar.gz
linhes_pkgbuild-13b02bb7a18ddb858e1fb88ef6e762eabd4fcafd.tar.bz2
python: up to latest
Diffstat (limited to 'abs/core/python/python-internal-expat.patch')
-rw-r--r--abs/core/python/python-internal-expat.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core/python/python-internal-expat.patch b/abs/core/python/python-internal-expat.patch
new file mode 100644
index 0000000..86252ab
--- /dev/null
+++ b/abs/core/python/python-internal-expat.patch
@@ -0,0 +1,33 @@
+--- setup.py 2008-04-22 12:12:24.613554757 +0300
++++ setup.py 2008-04-22 12:13:09.276544063 +0300
+@@ -1035,18 +1035,15 @@
+ #
+ # More information on Expat can be found at www.libexpat.org.
+ #
+- expatinc = os.path.join(os.getcwd(), srcdir, 'Modules', 'expat')
+- define_macros = [
+- ('HAVE_EXPAT_CONFIG_H', '1'),
+- ]
++ # Use system expat
++ expatinc = '/usr/include'
++ define_macros = []
+
+ exts.append(Extension('pyexpat',
+ define_macros = define_macros,
+ include_dirs = [expatinc],
++ libraries = ['expat'],
+ sources = ['pyexpat.c',
+- 'expat/xmlparse.c',
+- 'expat/xmlrole.c',
+- 'expat/xmltok.c',
+ ],
+ ))
+
+@@ -1058,6 +1055,7 @@
+ exts.append(Extension('_elementtree',
+ define_macros = define_macros,
+ include_dirs = [expatinc],
++ libraries = ['expat'],
+ sources = ['_elementtree.c'],
+ ))
+