summaryrefslogtreecommitdiffstats
path: root/abs/core/python2-contextlib2
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/python2-contextlib2
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python2-contextlib2')
-rw-r--r--abs/core/python2-contextlib2/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/python2-contextlib2/PKGBUILD b/abs/core/python2-contextlib2/PKGBUILD
new file mode 100644
index 0000000..43bd8cf
--- /dev/null
+++ b/abs/core/python2-contextlib2/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Cedric Girard <girard.cedric@gmail.com>
+
+_pypiname=contextlib2
+pkgname=python2-contextlib2
+pkgver=0.5.5
+pkgrel=1
+pkgdesc="contextlib2 is a backport of the standard library’s contextlib module to earlier Python versions"
+arch=('any')
+url="http://pypi.python.org/pypi/${_pypiname}"
+license=('PSF')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("https://pypi.io/packages/source/${_pypiname:0:1}/${_pypiname}/${_pypiname}-$pkgver.tar.gz")
+sha512sums=('d5c97ff8eef7d8b14da0bfdc3515f8019bcc05e24cb922ce08ca2366d5182b029d873bbf172e9e6791297df05e24f6faf40868550063dcdb54f451b14c9e505d')
+
+build() {
+ cd "${srcdir}/${_pypiname}-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd ${_pypiname}-$pkgver
+ python2 setup.py install --root="${pkgdir}"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}