summaryrefslogtreecommitdiffstats
path: root/abs/core/python2-distribute/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
commit5c40bb464357d486339e90f4118e4adaa8989e09 (patch)
tree8b5f680e7867c24eb5f3d1347eef9ea19c92beeb /abs/core/python2-distribute/PKGBUILD
parentf9b90df04a227fb2607482bed9a2f56678d95d30 (diff)
parent59771e9d114b75eafb316e94b7612dda202edd83 (diff)
downloadlinhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.zip
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.gz
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/python2-distribute/PKGBUILD')
-rw-r--r--abs/core/python2-distribute/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/core/python2-distribute/PKGBUILD b/abs/core/python2-distribute/PKGBUILD
new file mode 100644
index 0000000..f21be1d
--- /dev/null
+++ b/abs/core/python2-distribute/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Sebastien Binet <binet@farnsworth>
+pkgname=python2-distribute
+pkgver=0.6.14
+pkgrel=4
+pkgdesc="A collection of extensions to the Python 2 distutils"
+arch=('any')
+license=('PSF')
+url="http://packages.python.org/distribute"
+depends=('python2')
+conflicts=('setuptools')
+replaces=('setuptools')
+provides=('setuptools=0.6c11')
+source=(http://pypi.python.org/packages/source/d/distribute/distribute-${pkgver}.tar.gz
+ distribute-${pkgver}_python2_and_3.patch)
+sha1sums=('6bea50b97f36bf751548bb486a534204a690aa4d'
+ 'de635febfb11dc6878e5bdbac4a0e1d539c19d79')
+
+package() {
+ cd ${srcdir}/distribute-${pkgver}
+ patch -Np1 -i ../distribute-${pkgver}_python2_and_3.patch
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+}
+# vim: set noexpandtab tabstop=8 shiftwidth=8 textwidth=132 autoindent