summaryrefslogtreecommitdiffstats
path: root/abs/core/python2
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-10 00:19:00 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-10 00:19:00 (GMT)
commit5ab2c2d585290fb77dfc8d3670361df2fdc11c62 (patch)
tree58fc24f3a355bff701d6e93ba8011e9d1764f7b9 /abs/core/python2
parent4592612b015ff899ef52f33d96b52b5c60587ebb (diff)
downloadlinhes_pkgbuild-5ab2c2d585290fb77dfc8d3670361df2fdc11c62.zip
linhes_pkgbuild-5ab2c2d585290fb77dfc8d3670361df2fdc11c62.tar.gz
linhes_pkgbuild-5ab2c2d585290fb77dfc8d3670361df2fdc11c62.tar.bz2
A whole lotta housekeeping
Diffstat (limited to 'abs/core/python2')
-rw-r--r--abs/core/python2/Python-2.4.4-gdbm-1.patch17
-rw-r--r--abs/core/python2/Python-2.5.2-idlelib.patch17
-rw-r--r--abs/core/python2/db4.6-setup.py-detection.patch11
-rw-r--r--abs/core/python2/python-2.5.CVE-2007-4965-int-overflow.patch217
-rw-r--r--abs/core/python2/python-2.6-gdbm.patch12
-rw-r--r--abs/core/python2/python-2.7-db51.diff42
6 files changed, 0 insertions, 316 deletions
diff --git a/abs/core/python2/Python-2.4.4-gdbm-1.patch b/abs/core/python2/Python-2.4.4-gdbm-1.patch
deleted file mode 100644
index 4b6c7eb..0000000
--- a/abs/core/python2/Python-2.4.4-gdbm-1.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- Python-2.4.4/setup.py.orig 2007-01-14 12:50:46.000000000 -0600
-+++ Python-2.4.4/setup.py 2007-01-14 12:54:02.000000000 -0600
-@@ -685,12 +685,12 @@
- if self.compiler.find_library_file(lib_dirs, 'ndbm'):
- ndbm_libs = ['ndbm']
- else:
-- ndbm_libs = []
-+ ndbm_libs = ['gdbm', 'gdbm_compat']
- exts.append( Extension('dbm', ['dbmmodule.c'],
- define_macros=[('HAVE_NDBM_H',None)],
- libraries = ndbm_libs ) )
- elif (self.compiler.find_library_file(lib_dirs, 'gdbm')
-- and find_file("gdbm/ndbm.h", inc_dirs, []) is not None):
-+ and find_file("ndbm.h", inc_dirs, []) is not None):
- exts.append( Extension('dbm', ['dbmmodule.c'],
- define_macros=[('HAVE_GDBM_NDBM_H',None)],
- libraries = ['gdbm'] ) )
diff --git a/abs/core/python2/Python-2.5.2-idlelib.patch b/abs/core/python2/Python-2.5.2-idlelib.patch
deleted file mode 100644
index 50c987a..0000000
--- a/abs/core/python2/Python-2.5.2-idlelib.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- Lib/idlelib/WidgetRedirector.py.orig 2008-04-23 23:39:57.000000000 -0700
-+++ Lib/idlelib/WidgetRedirector.py 2008-04-23 23:46:55.000000000 -0700
-@@ -53,7 +53,13 @@
- if m:
- return m(*args)
- else:
-- return self.tk.call((self.orig, cmd) + args)
-+ #return self.tk.call((self.orig, cmd) + args)
-+ r = self.tk.call((self.orig, cmd) + args)
-+ if isinstance(r, tuple):
-+ # convert to string ourselves so we get a Tcl list
-+ # that can be converted back into a tuple
-+ r = ' '.join(map(str, r))
-+ return r
- except TclError:
- return ""
-
diff --git a/abs/core/python2/db4.6-setup.py-detection.patch b/abs/core/python2/db4.6-setup.py-detection.patch
deleted file mode 100644
index 873f175..0000000
--- a/abs/core/python2/db4.6-setup.py-detection.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py 2008-02-23 20:58:52.000000000 +0000
-+++ setup.py.new 2008-02-23 21:04:18.000000000 +0000
-@@ -608,7 +608,7 @@
- # a release. Most open source OSes come with one or more
- # versions of BerkeleyDB already installed.
-
-- max_db_ver = (4, 5)
-+ max_db_ver = (4, 6)
- # NOTE: while the _bsddb.c code links against BerkeleyDB 4.6.x
- # we leave that version disabled by default as it has proven to be
- # quite a buggy library release on many platforms.
diff --git a/abs/core/python2/python-2.5.CVE-2007-4965-int-overflow.patch b/abs/core/python2/python-2.5.CVE-2007-4965-int-overflow.patch
deleted file mode 100644
index 843acbf..0000000
--- a/abs/core/python2/python-2.5.CVE-2007-4965-int-overflow.patch
+++ /dev/null
@@ -1,217 +0,0 @@
-diff -rup Python-2.5-orig/Modules/imageop.c Python-2.5/Modules/imageop.c
---- Python-2.5-orig/Modules/imageop.c 2006-01-19 01:09:39.000000000 -0500
-+++ Python-2.5/Modules/imageop.c 2007-09-19 16:42:44.000000000 -0400
-@@ -78,7 +78,7 @@ imageop_crop(PyObject *self, PyObject *a
- char *cp, *ncp;
- short *nsp;
- Py_Int32 *nlp;
-- int len, size, x, y, newx1, newx2, newy1, newy2;
-+ int len, size, x, y, newx1, newx2, newy1, newy2, nlen;
- int ix, iy, xstep, ystep;
- PyObject *rv;
-
-@@ -90,13 +90,19 @@ imageop_crop(PyObject *self, PyObject *a
- PyErr_SetString(ImageopError, "Size should be 1, 2 or 4");
- return 0;
- }
-- if ( len != size*x*y ) {
-+ /* ( len != size*x*y ) */
-+ if ( size != ((len / x) / y) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
- xstep = (newx1 < newx2)? 1 : -1;
- ystep = (newy1 < newy2)? 1 : -1;
-
-+ nlen = (abs(newx2-newx1)+1)*(abs(newy2-newy1)+1)*size;
-+ if ( size != ((nlen / (abs(newx2-newx1)+1)) / (abs(newy2-newy1)+1)) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- rv = PyString_FromStringAndSize(NULL,
- (abs(newx2-newx1)+1)*(abs(newy2-newy1)+1)*size);
- if ( rv == 0 )
-@@ -132,7 +138,7 @@ imageop_scale(PyObject *self, PyObject *
- char *cp, *ncp;
- short *nsp;
- Py_Int32 *nlp;
-- int len, size, x, y, newx, newy;
-+ int len, size, x, y, newx, newy, nlen;
- int ix, iy;
- int oix, oiy;
- PyObject *rv;
-@@ -145,12 +151,18 @@ imageop_scale(PyObject *self, PyObject *
- PyErr_SetString(ImageopError, "Size should be 1, 2 or 4");
- return 0;
- }
-- if ( len != size*x*y ) {
-+ /* ( len != size*x*y ) */
-+ if ( size != ((len / x) / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
-+ nlen = newx*newy*size;
-+ if ( size != ((nlen / newx) / newy) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-
-- rv = PyString_FromStringAndSize(NULL, newx*newy*size);
-+ rv = PyString_FromStringAndSize(NULL, nlen);
- if ( rv == 0 )
- return 0;
- ncp = (char *)PyString_AsString(rv);
-@@ -190,7 +202,8 @@ imageop_tovideo(PyObject *self, PyObject
- PyErr_SetString(ImageopError, "Size should be 1 or 4");
- return 0;
- }
-- if ( maxx*maxy*width != len ) {
-+ /* if ( maxx*maxy*width != len ) */
-+ if ( maxx != ((len / maxy) / maxz) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -240,7 +253,8 @@ imageop_grey2mono(PyObject *self, PyObje
- if ( !PyArg_ParseTuple(args, "s#iii", &cp, &len, &x, &y, &tres) )
- return 0;
-
-- if ( x*y != len ) {
-+ /* ( x*y != len ) */
-+ if ( x != len / y ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -281,7 +295,8 @@ imageop_grey2grey4(PyObject *self, PyObj
- if ( !PyArg_ParseTuple(args, "s#ii", &cp, &len, &x, &y) )
- return 0;
-
-- if ( x*y != len ) {
-+ /* ( x*y != len ) */
-+ if ( x != len / y ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -320,7 +335,8 @@ imageop_grey2grey2(PyObject *self, PyObj
- if ( !PyArg_ParseTuple(args, "s#ii", &cp, &len, &x, &y) )
- return 0;
-
-- if ( x*y != len ) {
-+ /* ( x*y != len ) */
-+ if ( x != len / y ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -358,7 +374,8 @@ imageop_dither2mono(PyObject *self, PyOb
- if ( !PyArg_ParseTuple(args, "s#ii", &cp, &len, &x, &y) )
- return 0;
-
-- if ( x*y != len ) {
-+ /* ( x*y != len ) */
-+ if ( x != len / y ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -404,7 +421,8 @@ imageop_dither2grey2(PyObject *self, PyO
- if ( !PyArg_ParseTuple(args, "s#ii", &cp, &len, &x, &y) )
- return 0;
-
-- if ( x*y != len ) {
-+ /* ( x*y != len ) */
-+ if ( x != len / y ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -443,7 +461,11 @@ imageop_mono2grey(PyObject *self, PyObje
- if ( !PyArg_ParseTuple(args, "s#iiii", &cp, &len, &x, &y, &v0, &v1) )
- return 0;
-
-- nlen = x*y;
-+ nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( (nlen+7)/8 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -481,6 +503,10 @@ imageop_grey22grey(PyObject *self, PyObj
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( (nlen+3)/4 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -517,6 +543,10 @@ imageop_grey42grey(PyObject *self, PyObj
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( (nlen+1)/2 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -554,6 +584,10 @@ imageop_rgb2rgb8(PyObject *self, PyObjec
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( nlen*4 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -598,6 +632,10 @@ imageop_rgb82rgb(PyObject *self, PyObjec
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( nlen != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -648,6 +686,10 @@ imageop_rgb2grey(PyObject *self, PyObjec
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( nlen*4 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -693,6 +735,10 @@ imageop_grey2rgb(PyObject *self, PyObjec
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( nlen != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-diff -rup Python-2.5-orig/Modules/rgbimgmodule.c Python-2.5/Modules/rgbimgmodule.c
---- Python-2.5-orig/Modules/rgbimgmodule.c 2006-08-11 23:18:50.000000000 -0400
-+++ Python-2.5/Modules/rgbimgmodule.c 2007-09-19 17:00:06.000000000 -0400
-@@ -299,6 +299,11 @@ longimagedata(PyObject *self, PyObject *
- xsize = image.xsize;
- ysize = image.ysize;
- zsize = image.zsize;
-+ tablen = xsize * ysize * zsize * sizeof(Py_Int32);
-+ if (xsize != (((tablen / ysize) / zsize) / sizeof(Py_Int32))) {
-+ PyErr_NoMemory();
-+ goto finally;
-+ }
- if (rle) {
- tablen = ysize * zsize * sizeof(Py_Int32);
- starttab = (Py_Int32 *)malloc(tablen);
diff --git a/abs/core/python2/python-2.6-gdbm.patch b/abs/core/python2/python-2.6-gdbm.patch
deleted file mode 100644
index 0f223f6..0000000
--- a/abs/core/python2/python-2.6-gdbm.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur Python-2.6-old/setup.py Python-2.6/setup.py
---- Python-2.6-old/setup.py 2008-09-30 10:15:45.000000000 +1000
-+++ Python-2.6/setup.py 2008-12-07 16:04:01.000000000 +1000
-@@ -1013,7 +1013,7 @@
- if self.compiler.find_library_file(lib_dirs, 'ndbm'):
- ndbm_libs = ['ndbm']
- else:
-- ndbm_libs = []
-+ ndbm_libs = ['gdbm', 'gdbm_compat']
- exts.append( Extension('dbm', ['dbmmodule.c'],
- define_macros=[('HAVE_NDBM_H',None)],
- libraries = ndbm_libs ) )
diff --git a/abs/core/python2/python-2.7-db51.diff b/abs/core/python2/python-2.7-db51.diff
deleted file mode 100644
index 2da95c3..0000000
--- a/abs/core/python2/python-2.7-db51.diff
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -Naur Python-2.7-orig//Modules/_bsddb.c Python-2.7/Modules/_bsddb.c
---- Python-2.7-orig//Modules/_bsddb.c 2010-05-10 00:46:46.000000000 +1000
-+++ Python-2.7/Modules/_bsddb.c 2010-10-20 13:19:26.436669911 +1000
-@@ -9765,8 +9765,11 @@
-
- ADD_INT(d, DB_REP_PERMANENT);
-
--#if (DBVER >= 44)
-+#if (DBVER >= 44) && (DBVER <= 48)
- ADD_INT(d, DB_REP_CONF_NOAUTOINIT);
-+#endif
-+
-+#if (DBVER >= 44)
- ADD_INT(d, DB_REP_CONF_DELAYCLIENT);
- ADD_INT(d, DB_REP_CONF_BULK);
- ADD_INT(d, DB_REP_CONF_NOWAIT);
-diff -Naur Python-2.7-orig//setup.py Python-2.7/setup.py
---- Python-2.7-orig//setup.py 2010-06-27 22:36:16.000000000 +1000
-+++ Python-2.7/setup.py 2010-10-20 13:10:48.256670026 +1000
-@@ -765,7 +765,7 @@
- # a release. Most open source OSes come with one or more
- # versions of BerkeleyDB already installed.
-
-- max_db_ver = (4, 8)
-+ max_db_ver = (5, 1)
- min_db_ver = (4, 1)
- db_setup_debug = False # verbose debug prints from this script?
-
-@@ -787,8 +787,12 @@
- return True
-
- def gen_db_minor_ver_nums(major):
-- if major == 4:
-+ if major == 5:
- for x in range(max_db_ver[1]+1):
-+ if allow_db_ver((5, x)):
-+ yield x
-+ if major == 4:
-+ for x in range(9):
- if allow_db_ver((4, x)):
- yield x
- elif major == 3: