summaryrefslogtreecommitdiffstats
path: root/abs/core/python2
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-03-15 12:28:45 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-03-15 12:28:45 (GMT)
commit76fc068e082832f1721be260e11792f0a7df9b3a (patch)
treef8e686f455a20232f5ed84d6bd20f1679c37e7ea /abs/core/python2
parent47f205ef492e07410c2e410fe42abb2e62a7f682 (diff)
downloadlinhes_pkgbuild-76fc068e082832f1721be260e11792f0a7df9b3a.zip
linhes_pkgbuild-76fc068e082832f1721be260e11792f0a7df9b3a.tar.gz
linhes_pkgbuild-76fc068e082832f1721be260e11792f0a7df9b3a.tar.bz2
python2: update to 2.7.11
Diffstat (limited to 'abs/core/python2')
-rw-r--r--abs/core/python2/PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/abs/core/python2/PKGBUILD b/abs/core/python2/PKGBUILD
index a9d67a1..8615d48 100644
--- a/abs/core/python2/PKGBUILD
+++ b/abs/core/python2/PKGBUILD
@@ -5,22 +5,22 @@
# Contributor: Jason Chu <jason@archlinux.org>
pkgname=python2
-pkgver=2.7.9
-pkgrel=1
+pkgver=2.7.11
+pkgrel=2
_pybasever=2.7
pkgdesc="A high-level scripting language"
arch=('i686' 'x86_64')
license=('PSF')
url="http://www.python.org/"
depends=('bzip2' 'gdbm' 'openssl' 'zlib' 'expat' 'sqlite' 'libffi')
-makedepends=('tk' 'bluez-libs')
-checkdepends=('gdb')
+makedepends=('tk' 'bluez-libs' 'hardening-wrapper')
+checkdepends=('gdb' 'file')
optdepends=('tk: for IDLE'
'python2-setuptools'
'python2-pip')
conflicts=('python<3')
source=(http://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz)
-sha1sums=('3172f6e957713c2d9fca462cc16068222fd1b9d3')
+sha1sums=('c3b8bbe3f084c4d4ea13ffb03d75a5e22f9756ff')
prepare() {
cd Python-${pkgver}
@@ -53,8 +53,8 @@ prepare() {
find . -name '*.py' | \
xargs sed -i "s|#[ ]*![ ]*/usr/bin/env python$|#!/usr/bin/env python2|"
- # Workaround asdl_c.py error after we touched the shebangs
- touch Include/Python-ast.h Python/Python-ast.c
+ # Workaround asdl_c.py/makeopcodetargets.py errors after we touched the shebangs
+ touch Include/Python-ast.h Python/Python-ast.c Python/opcode_targets.h
}
build() {
@@ -75,12 +75,14 @@ build() {
}
check() {
- # As of 2.7.9, 2 tests failed:
- # test_gdb test_mhlib
+ # As of 2.7.11, 2 tests failed:
+ # test_doctest test_gdb
# Besides, test_thread disabled as it will stuck
+
+ # $SHELL was set to avoid a test failure in test_gdb (it still fails due to other reasons, though)
cd Python-${pkgver}
- LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
+ SHELL=/bin/sh LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
"${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_thread || warning "Tests failed"
}