summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/gitpython/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-11-09 18:24:42 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-11-09 18:24:42 (GMT)
commitab2f21200aef65b575bb080edd472d3a789495c2 (patch)
tree7b839452dff46b0cd4ecf983764ec7908af5507e /abs/core/python_modules/gitpython/PKGBUILD
parentfaaa8f74f6ded7d3273bb71847cc61e2b7ea3c0a (diff)
parent361571020eee92e577ab71d6386bf976aa0af196 (diff)
downloadlinhes_pkgbuild-ab2f21200aef65b575bb080edd472d3a789495c2.zip
linhes_pkgbuild-ab2f21200aef65b575bb080edd472d3a789495c2.tar.gz
linhes_pkgbuild-ab2f21200aef65b575bb080edd472d3a789495c2.tar.bz2
Merge branch 'testing' of ssh://jams@linhes.org/mount/repository/linhes_pkgbuild into testingR7.1
Diffstat (limited to 'abs/core/python_modules/gitpython/PKGBUILD')
-rw-r--r--abs/core/python_modules/gitpython/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/abs/core/python_modules/gitpython/PKGBUILD b/abs/core/python_modules/gitpython/PKGBUILD
new file mode 100644
index 0000000..5b4d975
--- /dev/null
+++ b/abs/core/python_modules/gitpython/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Jon Bergli Heier <snakebite@jvnv.net>
+pkgname=gitpython
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="A python library used to interact with Git repositories"
+arch=('any')
+url="http://gitorious.org/git-python"
+license=('BSD')
+depends=('python2' 'git' 'python-gitdb')
+conflicts=('gitpython-git')
+source=("http://pypi.python.org/packages/source/G/GitPython/GitPython-${pkgver}.tar.gz")
+md5sums=('98f9a4e33574065660b7257fa93d707d')
+
+build() {
+ cd "$srcdir/GitPython-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 || return 1
+ install -D -m 644 LICENSE "$pkgdir"/usr/share/licenses/gitpython/LICENSE
+}
+# vim:set ts=2 sw=2 et:
+