summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/pyopengl
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/python_modules/pyopengl
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/pyopengl')
-rw-r--r--abs/core/python_modules/pyopengl/LICENSE30
-rw-r--r--abs/core/python_modules/pyopengl/PKGBUILD51
2 files changed, 81 insertions, 0 deletions
diff --git a/abs/core/python_modules/pyopengl/LICENSE b/abs/core/python_modules/pyopengl/LICENSE
new file mode 100644
index 0000000..11d88fb
--- /dev/null
+++ b/abs/core/python_modules/pyopengl/LICENSE
@@ -0,0 +1,30 @@
+# Copyright (c) 2006-2008 Alex Holkner
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of pyglet nor the names of its
+# contributors may be used to endorse or promote products
+# derived from this software without specific prior written
+# permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+# FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+# COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+# BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+# ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
diff --git a/abs/core/python_modules/pyopengl/PKGBUILD b/abs/core/python_modules/pyopengl/PKGBUILD
new file mode 100644
index 0000000..dbb05c9
--- /dev/null
+++ b/abs/core/python_modules/pyopengl/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Josh Taylor <joshtaylor.mail@gmail.com>
+# Contributor: simo <simo@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgbase=pyopengl
+pkgname=('python2-opengl' 'python-opengl')
+pkgver=3.1.0
+pkgrel=3
+pkgdesc="The cross platform Python binding to OpenGL and related APIs"
+url="http://pyopengl.sourceforge.net/"
+license=('BSD')
+arch=('any')
+makedepends=('freeglut' 'python2-setuptools' 'python-setuptools')
+source=("https://pypi.python.org/packages/source/P/PyOpenGL/PyOpenGL-${pkgver}.tar.gz"
+ 'LICENSE')
+md5sums=('0de021941018d46d91e5a8c11c071693'
+ '0b53c508a63e5dbaf44cdfb0fa103b3a')\
+
+prepare() {
+ cp -a PyOpenGL-${pkgver} python-PyOpenGL-${pkgver}
+
+ # Fix the shebang
+ sed -i 's|#!/usr/bin/env python|#!/usr/bin/python2|' \
+ PyOpenGL-${pkgver}/OpenGL/Tk/__init__.py
+ sed -i 's|#! /usr/bin/env python|#!/usr/bin/python2|' \
+ PyOpenGL-${pkgver}/OpenGL/arrays/{_,}buffers.py
+}
+
+package_python2-opengl() {
+ depends=('python2' 'freeglut')
+ conflicts=('python-pyopengl' 'python-opengl<=3.0.1-4')
+ replaces=('python-pyopengl' 'python-opengl<=3.0.1-4')
+
+ cd PyOpenGL-${pkgver}
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python-opengl() {
+ depends=('python' 'freeglut')
+
+ cd python-PyOpenGL-${pkgver}
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+