summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python-beautifulsoup4/PKGBUILD
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-beautifulsoup4/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
new file mode 100644
index 0000000..9af6084
--- /dev/null
+++ b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
@@ -0,0 +1,57 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+pkgbase=python-beautifulsoup4
+pkgname=('python2-beautifulsoup4')
+pkgver=4.6.0
+pkgrel=1
+pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
+arch=('any')
+url="http://www.crummy.com/software/BeautifulSoup/index.html"
+license=('PSF')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest')
+source=("http://www.crummy.com/software/BeautifulSoup/bs4/download/${pkgver%.*}/${pkgbase#*-}-$pkgver.tar.gz")
+sha512sums=('1a7eee4218e58cc3852e71fe4f0892f673bb46a851941264766a38eff8ef05d612d88b4641fcb478ce8f66ac50dc987ca039923c4bbb11867c74813289f7e578')
+
+prepare() {
+ cp -a beautifulsoup4-$pkgver{,-py2}
+}
+
+build() {
+# cd "$srcdir"/beautifulsoup4-$pkgver
+# python setup.py build
+
+ cd "$srcdir"/beautifulsoup4-$pkgver-py2
+ python2 setup.py build
+}
+
+check() {
+# cd "$srcdir"/beautifulsoup4-$pkgver/build
+# py.test
+
+ cd "$srcdir"/beautifulsoup4-$pkgver-py2/build
+ py.test2
+}
+
+package_python-beautifulsoup4() {
+ depends=('python')
+ optdepends=('python-chardet: to autodetect character encodings'
+ 'python-lxml: alternative HTML parser'
+ 'python-html5lib: alternative HTML parser')
+
+ cd beautifulsoup4-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+package_python2-beautifulsoup4() {
+ depends=('python2')
+ optdepends=('python2-chardet: to autodetect character encodings'
+ 'python2-lxml: alternative HTML parser'
+ 'python2-html5lib: alternative HTML parser')
+
+ cd beautifulsoup4-$pkgver-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}