summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-beautifulsoup4
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-07-16 02:09:53 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-07-16 02:09:53 (GMT)
commit599b8835d6583229f4344d459e74cdc27b47f81c (patch)
tree98dac8258f271d8fdb6e71a27b7d276ccea38eaf /abs/core/python_modules/python-beautifulsoup4
parent781668561dc736c45bf203629bebd21bb1a3002d (diff)
downloadlinhes_pkgbuild-599b8835d6583229f4344d459e74cdc27b47f81c.zip
linhes_pkgbuild-599b8835d6583229f4344d459e74cdc27b47f81c.tar.gz
linhes_pkgbuild-599b8835d6583229f4344d459e74cdc27b47f81c.tar.bz2
python-beautifulsoup4: initial inclusion. dep of flexget
Diffstat (limited to 'abs/core/python_modules/python-beautifulsoup4')
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/PKGBUILD57
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/__changelog2
2 files changed, 59 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
new file mode 100644
index 0000000..9af6084
--- /dev/null
+++ b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
@@ -0,0 +1,57 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+pkgbase=python-beautifulsoup4
+pkgname=('python2-beautifulsoup4')
+pkgver=4.6.0
+pkgrel=1
+pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
+arch=('any')
+url="http://www.crummy.com/software/BeautifulSoup/index.html"
+license=('PSF')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest')
+source=("http://www.crummy.com/software/BeautifulSoup/bs4/download/${pkgver%.*}/${pkgbase#*-}-$pkgver.tar.gz")
+sha512sums=('1a7eee4218e58cc3852e71fe4f0892f673bb46a851941264766a38eff8ef05d612d88b4641fcb478ce8f66ac50dc987ca039923c4bbb11867c74813289f7e578')
+
+prepare() {
+ cp -a beautifulsoup4-$pkgver{,-py2}
+}
+
+build() {
+# cd "$srcdir"/beautifulsoup4-$pkgver
+# python setup.py build
+
+ cd "$srcdir"/beautifulsoup4-$pkgver-py2
+ python2 setup.py build
+}
+
+check() {
+# cd "$srcdir"/beautifulsoup4-$pkgver/build
+# py.test
+
+ cd "$srcdir"/beautifulsoup4-$pkgver-py2/build
+ py.test2
+}
+
+package_python-beautifulsoup4() {
+ depends=('python')
+ optdepends=('python-chardet: to autodetect character encodings'
+ 'python-lxml: alternative HTML parser'
+ 'python-html5lib: alternative HTML parser')
+
+ cd beautifulsoup4-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+package_python2-beautifulsoup4() {
+ depends=('python2')
+ optdepends=('python2-chardet: to autodetect character encodings'
+ 'python2-lxml: alternative HTML parser'
+ 'python2-html5lib: alternative HTML parser')
+
+ cd beautifulsoup4-$pkgver-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
diff --git a/abs/core/python_modules/python-beautifulsoup4/__changelog b/abs/core/python_modules/python-beautifulsoup4/__changelog
new file mode 100644
index 0000000..4f818ef
--- /dev/null
+++ b/abs/core/python_modules/python-beautifulsoup4/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: don't build py 3 stuff
+