summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-chardet
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python-chardet
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-chardet')
-rw-r--r--abs/core/python_modules/python-chardet/PKGBUILD38
-rw-r--r--abs/core/python_modules/python-chardet/__changelog2
2 files changed, 40 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-chardet/PKGBUILD b/abs/core/python_modules/python-chardet/PKGBUILD
new file mode 100644
index 0000000..13bc9fa
--- /dev/null
+++ b/abs/core/python_modules/python-chardet/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer : Felix Yan <felixonmars@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgbase=python-chardet
+pkgname=('python2-chardet')
+pkgver=3.0.4
+pkgrel=1
+arch=('any')
+url="https://github.com/chardet/chardet"
+license=('LGPL')
+makedepends=('python2-setuptools')
+source=("https://pypi.io/packages/source/c/chardet/chardet-${pkgver}.tar.gz")
+sha512sums=('61a03b23447a2bfe52ceed4dd1b9afdb5784da1933a623776883ee9f297e341f633e27f0ce0230bd5fdc5fdb5382105ab42736a74a417ddeb9f83af57455dba5')
+
+prepare() {
+ cp -a chardet-$pkgver{,-py2}
+}
+
+package_python-chardet() {
+ depends=('python-setuptools')
+ pkgdesc="Python3 module for character encoding auto-detection"
+
+ cd chardet-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python2-chardet() {
+ depends=('python2-setuptools')
+ pkgdesc="Python2 module for character encoding auto-detection"
+
+ cd chardet-$pkgver-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ # To avoid file conflict with the python3 version
+ mv "$pkgdir"/usr/bin/chardetect{,-py2}
+}
diff --git a/abs/core/python_modules/python-chardet/__changelog b/abs/core/python_modules/python-chardet/__changelog
new file mode 100644
index 0000000..4f818ef
--- /dev/null
+++ b/abs/core/python_modules/python-chardet/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: don't build py 3 stuff
+