summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-cherrypy/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python-cherrypy/PKGBUILD
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-cherrypy/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-cherrypy/PKGBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-cherrypy/PKGBUILD b/abs/core/python_modules/python-cherrypy/PKGBUILD
new file mode 100644
index 0000000..5fd491b
--- /dev/null
+++ b/abs/core/python_modules/python-cherrypy/PKGBUILD
@@ -0,0 +1,60 @@
+# $Id$
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Kaiting Chen <kaitocracy@gmail.com>
+# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+# Contributor: Armando M. Baratti <amblistas@ajato.com.br>
+# Contributor: Florian Richter <Florian_Richter@gmx.de>
+pkgname=('python2-cherrypy')
+pkgver=8.9.1
+pkgrel=1
+pkgdesc="A pythonic, object-oriented web development framework"
+arch=('any')
+url="http://www.cherrypy.org"
+license=('BSD')
+makedepends=('python2' 'python2-setuptools')
+checkdepends=('python2-mock')
+source=("https://pypi.python.org/packages/56/aa/91005730bdc5c0da8291a2f411aacbc5c3729166c382e2193e33f28044a3/CherryPy-8.9.1.tar.gz")
+md5sums=('7abe5198e48f14cfee57a07d23875a4b')
+
+build() {
+ cp -r CherryPy-${pkgver} CherryPy-${pkgver}-py2
+
+# cd CherryPy-${pkgver}
+# python ./setup.py build
+
+ cd "${srcdir}/CherryPy-${pkgver}-py2"
+ python2 ./setup.py build
+}
+
+package_python-cherrypy() {
+ depends=('python' 'python-six')
+
+ cd CherryPy-${pkgver}
+
+ python ./setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm644 LICENSE.md \
+ "${pkgdir}/usr/share/licenses/python-cherrypy/LICENSE.md"
+}
+
+package_python2-cherrypy() {
+ depends=('python2')
+
+ cd CherryPy-${pkgver}-py2
+
+ python2 ./setup.py install --root="${pkgdir}" --optimize=1
+ mv "${pkgdir}/usr/bin/cherryd" "${pkgdir}/usr/bin/cherryd2"
+
+ install -Dm644 LICENSE.md \
+ "${pkgdir}/usr/share/licenses/python2-cherrypy/LICENSE.md"
+}
+
+check() {
+ # backports.unittest_mock is not packaged..
+ cd CherryPy-${pkgver}-py2/cherrypy
+ #LANG="en_US.UTF-8" pytest2 test/
+
+ cd $srcdir/CherryPy-${pkgver}/cherrypy
+ LANG="en_US.UTF-8" nosetests test/
+
+}