summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-ifaddr/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-10-25 17:05:26 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-10-25 17:05:26 (GMT)
commit7b41a9288f5d1332c8136df798bb8ca2465bc21c (patch)
tree8551ce40362a5d6191c918f1e5652f9350cce09f /abs/core/python_modules/python-ifaddr/PKGBUILD
parent5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (diff)
parent0a4d5cece8f6b3148a61c6358026fdf2eb81cdb2 (diff)
downloadlinhes_pkgbuild-7b41a9288f5d1332c8136df798bb8ca2465bc21c.zip
linhes_pkgbuild-7b41a9288f5d1332c8136df798bb8ca2465bc21c.tar.gz
linhes_pkgbuild-7b41a9288f5d1332c8136df798bb8ca2465bc21c.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-ifaddr/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-ifaddr/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-ifaddr/PKGBUILD b/abs/core/python_modules/python-ifaddr/PKGBUILD
new file mode 100644
index 0000000..4e06e8e
--- /dev/null
+++ b/abs/core/python_modules/python-ifaddr/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jelle van der Waa <jelle@archlinux.org>
+
+_name=ifaddr
+pkgname=python-ifaddr
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="Enumerates all IP addresses on all network adapters of the system"
+arch=('any')
+url="https://github.com/pydron/ifaddr"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+checkdepends=('python-nose')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.zip)
+sha512sums=('5b080d8f328f7a974644e15929850ba93b9232cee545740d89e4d63e982e351287504befef365834bfb3f4c5f25dc99f4a4d76753405658ae197590e2ce94929')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python3 setup.py build
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
+
+check() {
+ cd "${_name}-${pkgver}"
+ nosetests ${_name}/test_ifaddr.py
+}
+
+# vim:set ts=2 sw=2 et: