summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-iplib/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
commit5c40bb464357d486339e90f4118e4adaa8989e09 (patch)
tree8b5f680e7867c24eb5f3d1347eef9ea19c92beeb /abs/core/python_modules/python-iplib/PKGBUILD
parentf9b90df04a227fb2607482bed9a2f56678d95d30 (diff)
parent59771e9d114b75eafb316e94b7612dda202edd83 (diff)
downloadlinhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.zip
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.gz
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/python_modules/python-iplib/PKGBUILD')
-rwxr-xr-xabs/core/python_modules/python-iplib/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-iplib/PKGBUILD b/abs/core/python_modules/python-iplib/PKGBUILD
new file mode 100755
index 0000000..39d0b55
--- /dev/null
+++ b/abs/core/python_modules/python-iplib/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=python-iplib
+_libname=iplib
+pkgver=1.1
+pkgrel=3
+pkgdesc="IPlib is a Python module useful to convert amongst many different notations and to manage couples of address/netmask in the CIDR notation."
+url="http://www.pymedia.org"
+arch=('i686')
+license=('GPL')
+depends=('python2')
+#makedepends=('python2>=2.3')
+source=(http://erlug.linux.it/~da/soft/iplib/iplib-1.1.tar.gz)
+md5sums=('3437ddbfc1986b2d06e7f4a0724ac5a0')
+
+build() {
+ cd ${srcdir}/${_libname}-${pkgver}
+
+ find "$srcdir/${_libname}-${pkgver}" -name '*.py' | \
+ xargs sed -i "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|"
+
+ yes "" | python2 setup.py install --root=${pkgdir} --prefix=/usr
+
+ find "$pkgdir/" -name '*.py' | \
+ xargs sed -i "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|"
+
+}