summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-jsonschema/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python-jsonschema/PKGBUILD
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-jsonschema/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-jsonschema/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-jsonschema/PKGBUILD b/abs/core/python_modules/python-jsonschema/PKGBUILD
new file mode 100644
index 0000000..45de390
--- /dev/null
+++ b/abs/core/python_modules/python-jsonschema/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer: Daniel Wallace <danielwallace at gtmanfred.com>
+# Contributor: Bogdan Szczurek <thebodzio@gmail.com>
+# Contributor: Ismo Toijala <ismo.toijala@gmail.com>
+
+pkgbase=python-jsonschema
+_pkgname=jsonschema
+pkgname=(python2-jsonschema)
+pkgver=2.6.0
+pkgrel=1
+pkgdesc="An implementation of JSON Schema validation for Python"
+arch=(any)
+url="http://pypi.python.org/pypi/jsonschema"
+license=('MIT')
+makedepends=(python2-setuptools)
+source=("https://pypi.io/packages/source/j/jsonschema/${pkgname:8}-$pkgver.tar.gz")
+
+prepare(){
+ cp -a $_pkgname-$pkgver $_pkgname-$pkgver-2
+ find $_pkgname-$pkgver-2 -name \*.py -exec sed -i '1s/python$/&2/' {} +
+}
+
+package_python-jsonschema() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ depends=(python)
+ install -D -m644 json/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-jsonschema() {
+ cd "$srcdir/$_pkgname-$pkgver-2"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ depends=(python2-functools32)
+ install -D -m644 json/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ mv $pkgdir/usr/bin/jsonschema{,2}
+}
+
+md5sums=('50c6b69a373a8b55ff1e0ec6e78f13f4')