summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-ndg-httpsclient/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-ndg-httpsclient/PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD b/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
index 7b0047f..0d2f022 100644
--- a/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
+++ b/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
@@ -3,24 +3,25 @@
# Contributor: Hugo Osvaldo Barrera <hugo@osvaldobarrera.com.ar>
pkgbase=python-ndg-httpsclient
-pkgname=(python2-ndg-httpsclient)
+pkgname=(python-ndg-httpsclient python2-ndg-httpsclient)
_pkgname=ndg_httpsclient
-pkgver=0.4.2
-pkgrel=2
+pkgver=0.4.4
+pkgrel=1
pkgdesc="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
arch=(any)
url="https://pypi.python.org/pypi/ndg-httpsclient"
license=('BSD')
-makedepends=(python2-setuptools python2-pyopenssl python2-pyasn1)
+makedepends=(python2-setuptools python2-pyopenssl python2-pyasn1
+ python-setuptools python-pyopenssl python-pyasn1)
options=(!emptydirs)
source=(https://files.pythonhosted.org/packages/source/n/ndg-httpsclient/$_pkgname-$pkgver.tar.gz)
-sha256sums=('580987ef194334c50389e0d7de885fccf15605c13c6eecaabd8d6c43768eb8ac')
+sha256sums=('fba4d4798dcac2965874f24afb6631b4326baa4bd02505744d34f690c354856a')
build() {
cd "$srcdir"/$_pkgname-$pkgver
-# rm -rf ../buildpy3; mkdir ../buildpy3
-# python setup.py build -b ../buildpy3
+ rm -rf ../buildpy3; mkdir ../buildpy3
+ python setup.py build -b ../buildpy3
rm -rf ../buildpy2; mkdir ../buildpy2
python2 setup.py build -b ../buildpy2