summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-numpy
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/python_modules/python-numpy
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-numpy')
-rwxr-xr-xabs/core/python_modules/python-numpy/PKGBUILD78
-rw-r--r--abs/core/python_modules/python-numpy/__changelog1
-rw-r--r--abs/core/python_modules/python-numpy/site.cfg4
3 files changed, 55 insertions, 28 deletions
diff --git a/abs/core/python_modules/python-numpy/PKGBUILD b/abs/core/python_modules/python-numpy/PKGBUILD
index 8c9c6be..6c92605 100755
--- a/abs/core/python_modules/python-numpy/PKGBUILD
+++ b/abs/core/python_modules/python-numpy/PKGBUILD
@@ -1,61 +1,85 @@
-# $Id: PKGBUILD 138131 2011-09-17 03:10:10Z allan $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
pkgbase=python-numpy
-pkgname=('python2-numpy')
-pkgver=1.6.1
+pkgname=('python2-numpy' 'python-numpy')
+pkgver=1.14.2
pkgrel=1
pkgdesc="Scientific tools for Python"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('custom')
-url="http://numpy.scipy.org/"
-makedepends=('lapack' 'python2' 'python2-distribute' 'gcc-fortran' 'python2-nose')
-source=(http://downloads.sourceforge.net/numpy/numpy-${pkgver}.tar.gz)
-md5sums=('2bce18c08fc4fce461656f0f4dd9103e')
+url="http://www.numpy.org/"
+makedepends=('cblas' 'lapack' 'python' 'python2' 'python-setuptools' 'python2-setuptools' 'gcc-fortran'
+ 'python-nose' 'python2-nose' 'cython' 'cython2')
+options=('staticlibs')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/numpy/numpy/archive/v$pkgver.tar.gz" 'site.cfg')
+sha512sums=('65b10462011e033669b700f0688df2e8630a097323fc7d72e71549fdfc2258546fe6f1317e0d51e1a0c9ab86451e0998ccbc7daa9af690652a96034571d5b76b'
+ '03a0f161be4963625f110a26167efbd300a12bd4cf99c8250c47ac865466d03fc8640e7e4fb6a59c39bf8b797609f5ed50afbc720d1fcbd2c4c57263cf8b406b')
-build() {
- cd "${srcdir}"
- cp -a numpy-${pkgver} numpy-py2-${pkgver}
+prepare() {
+ cp site.cfg numpy-$pkgver
+ cp -a numpy-$pkgver numpy-py2-$pkgver
+ cd numpy-py2-$pkgver
+
+ sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
+ -i $(find . -name '*.py')
+}
- export Atlas=None
+build() {
export LDFLAGS="$LDFLAGS -shared"
echo "Building Python2"
- cd "${srcdir}/numpy-py2-${pkgver}"
+ cd numpy-py2-$pkgver
python2 setup.py config_fc --fcompiler=gnu95 build
- #echo "Building Python3"
- #cd "${srcdir}/numpy-${pkgver}"
- #python setup.py config_fc --fcompiler=gnu95 build
+ echo "Building Python3"
+ cd ../numpy-$pkgver
+ python setup.py config_fc --fcompiler=gnu95 build
}
package_python2-numpy() {
- depends=('lapack' 'python2')
- optdepends=('python-nose: testsuite')
+ depends=('lapack' 'python2' 'cblas')
+ optdepends=('python2-nose: testsuite')
+
+ _pyver=2.7
- cd "${srcdir}/numpy-py2-${pkgver}"
+ export ATLAS=None
+ export LDFLAGS="$LDFLAGS -shared"
+
+ cd numpy-py2-$pkgver
python2 setup.py config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}" --optimize=1
install -m755 -d "${pkgdir}/usr/share/licenses/python2-numpy"
install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-numpy/"
- sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
- $(find ${pkgdir} -name '*.py')
+ install -m755 -d "${pkgdir}/usr/include/python${_pyver}"
+ ln -sf /usr/lib/python${_pyver}/site-packages/numpy/core/include/numpy "${pkgdir}/usr/include/python${_pyver}/numpy"
}
package_python-numpy() {
- depends=('lapack' 'python')
+ depends=('lapack' 'python' 'cblas')
+ optdepends=('python-nose: testsuite')
provides=("python3-numpy=${pkgver}")
replaces=('python3-numpy')
conflicts=('python3-numpy')
- cd "${srcdir}/numpy-${pkgver}"
+ _pyver=3.6
+ _pyinc=3.6m
+
+ export ATLAS=None
+ export LDFLAGS="$LDFLAGS -shared"
+
+ cd numpy-$pkgver
python setup.py config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}" --optimize=1
- install -m755 -d "${pkgdir}/usr/share/licenses/python3-numpy"
- install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python3-numpy/"
+ install -m755 -d "${pkgdir}/usr/share/licenses/python-numpy"
+ install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-numpy/"
+
+ install -m755 -d "${pkgdir}/usr/include/python${_pyinc}"
+ ln -sf /usr/lib/python${_pyver}/site-packages/numpy/core/include/numpy "${pkgdir}/usr/include/python${_pyinc}/numpy"
}
diff --git a/abs/core/python_modules/python-numpy/__changelog b/abs/core/python_modules/python-numpy/__changelog
deleted file mode 100644
index 3bc4789..0000000
--- a/abs/core/python_modules/python-numpy/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-remove python3 support
diff --git a/abs/core/python_modules/python-numpy/site.cfg b/abs/core/python_modules/python-numpy/site.cfg
new file mode 100644
index 0000000..528d890
--- /dev/null
+++ b/abs/core/python_modules/python-numpy/site.cfg
@@ -0,0 +1,4 @@
+[atlas]
+atlas_libs = cblas
+libraries = cblas
+