summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-opengl/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-10 01:32:23 (GMT)
commit5c40bb464357d486339e90f4118e4adaa8989e09 (patch)
tree8b5f680e7867c24eb5f3d1347eef9ea19c92beeb /abs/core/python_modules/python-opengl/PKGBUILD
parentf9b90df04a227fb2607482bed9a2f56678d95d30 (diff)
parent59771e9d114b75eafb316e94b7612dda202edd83 (diff)
downloadlinhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.zip
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.gz
linhes_pkgbuild-5c40bb464357d486339e90f4118e4adaa8989e09.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/python_modules/python-opengl/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-opengl/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-opengl/PKGBUILD b/abs/core/python_modules/python-opengl/PKGBUILD
new file mode 100644
index 0000000..e4ff382
--- /dev/null
+++ b/abs/core/python_modules/python-opengl/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 89543 2010-09-01 17:18:01Z remy $
+# Contributor: Josh Taylor <joshtaylor.mail@gmail.com>
+# Contributor: simo <simo@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=python-opengl
+pkgver=3.0.1
+pkgrel=3
+pkgdesc="The cross platform Python binding to OpenGL and related APIs"
+url="http://pyopengl.sourceforge.net"
+license=('BSD')
+arch=('any')
+depends=('python2' 'tk' 'freeglut' 'setuptools')
+provides=('pyopengl' 'python-pyopengl')
+conflicts=('pyopengl' 'python-pyopengl')
+source=(http://downloads.sourceforge.net/pyopengl/PyOpenGL-${pkgver}.tar.gz
+ 'LICENSE')
+md5sums=('221d4a6a0928fcfeef26751370ec5f52'
+ '0b53c508a63e5dbaf44cdfb0fa103b3a')
+
+build() {
+ /bin/true
+}
+
+package() {
+ cd ${srcdir}/PyOpenGL-${pkgver}
+ python2 setup.py install --root=${pkgdir} || return 1
+ install -Dm644 ${srcdir}/LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}