summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-pip/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-07-16 02:18:55 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-07-16 02:18:55 (GMT)
commit71ff093002c10aaf942f90a649a6a6f03f914631 (patch)
treec2ddbf039b6cb9bc767bb7778efd32beab7b4d87 /abs/core/python_modules/python-pip/PKGBUILD
parent52d090c3f7ef15b0f52e0bd380243d91582bd38e (diff)
downloadlinhes_pkgbuild-71ff093002c10aaf942f90a649a6a6f03f914631.zip
linhes_pkgbuild-71ff093002c10aaf942f90a649a6a6f03f914631.tar.gz
linhes_pkgbuild-71ff093002c10aaf942f90a649a6a6f03f914631.tar.bz2
python-pip: initial inclusion. dep of flexget
Diffstat (limited to 'abs/core/python_modules/python-pip/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-pip/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-pip/PKGBUILD b/abs/core/python_modules/python-pip/PKGBUILD
new file mode 100644
index 0000000..acef38b
--- /dev/null
+++ b/abs/core/python_modules/python-pip/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Dan McGee <dan@archlinux.org>
+# Contributor: Sebastien Binet <binet@lblbox>
+
+pkgname=('python2-pip')
+pkgver=9.0.1
+pkgrel=2
+pkgdesc="The PyPA recommended tool for installing Python packages"
+url="https://pip.pypa.io/"
+arch=('any')
+license=('MIT')
+makedepends=('python2' 'python2-setuptools')
+source=(https://pypi.io/packages/source/p/pip/pip-${pkgver}.tar.gz)
+md5sums=('35f01da33009719497f01a4ba69d63c9')
+sha256sums=('09f243e1a7b461f654c26a725fa373211bb7ff17a9300058b205c61658ca940d')
+
+package_python-pip() {
+ depends=('python' 'python-setuptools')
+
+ cd "$srcdir/pip-$pkgver"
+ python setup.py build
+ python setup.py install --prefix=/usr --root="$pkgdir"
+
+ install -D -m644 LICENSE.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-pip() {
+ depends=('python2' 'python2-setuptools')
+ conflicts=('python-pyinstall')
+ replaces=('python-pyinstall')
+
+ cd "$srcdir/pip-$pkgver"
+ python2 setup.py build
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+
+ mv "$pkgdir/usr/bin/pip" "$pkgdir/usr/bin/pip2"
+ sed -i "s|#!/usr/bin/env python$|#!/usr/bin/env python2|" \
+ ${pkgdir}/usr/lib/python2.7/site-packages/pip/__init__.py
+ python2 -m compileall ${pkgdir}/usr/lib/python2.7/site-packages/pip/__init__.py
+
+ install -D -m644 LICENSE.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}