summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-pytest-runner/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/python_modules/python-pytest-runner/PKGBUILD
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-pytest-runner/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-pytest-runner/PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/abs/core/python_modules/python-pytest-runner/PKGBUILD b/abs/core/python_modules/python-pytest-runner/PKGBUILD
index 5d106ce..8928aa0 100644
--- a/abs/core/python_modules/python-pytest-runner/PKGBUILD
+++ b/abs/core/python_modules/python-pytest-runner/PKGBUILD
@@ -2,14 +2,14 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgbase=python-pytest-runner
-pkgname=('python2-pytest-runner')
+pkgname=('python-pytest-runner' 'python2-pytest-runner')
pkgver=2.11.1
-pkgrel=1
+pkgrel=2
pkgdesc="Invoke py.test as distutils command with dependency resolution"
arch=('any')
license=('MIT')
url="https://github.com/pytest-dev/pytest-runner"
-makedepends=('python2-pytest' 'python2-setuptools-scm' 'git')
+makedepends=('python-pytest' 'python-setuptools-scm' 'python2-pytest' 'python2-setuptools-scm' 'git')
source=("git+https://github.com/pytest-dev/pytest-runner.git#tag=$pkgver")
sha512sums=('SKIP')
@@ -18,17 +18,17 @@ prepare() {
}
build() {
-# cd "$srcdir"/pytest-runner
-# python setup.py build
+ cd "$srcdir"/pytest-runner
+ python setup.py build
cd "$srcdir"/pytest-runner-py2
python2 setup.py build
}
check() {
-# cd "$srcdir"/pytest-runner
-# python setup.py egg_info
-# PYTHONPATH="$PWD" pytest
+ cd "$srcdir"/pytest-runner
+ python setup.py egg_info
+ PYTHONPATH="$PWD" pytest
cd "$srcdir"/pytest-runner-py2
python2 setup.py egg_info