summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-simplejson
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-02-19 18:16:16 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-02-19 18:16:16 (GMT)
commit8de064f6e96f960cdbfe6868d9957a4613f704df (patch)
tree4e73a420991733450d013529c0fee60e0365297a /abs/core/python_modules/python-simplejson
parent0374b16f1e15ba1819b62bd5a6e0076ac7b243d0 (diff)
parent6fde8cd5e74f0840e01988e743464fe91c0a28f8 (diff)
downloadlinhes_pkgbuild-8de064f6e96f960cdbfe6868d9957a4613f704df.zip
linhes_pkgbuild-8de064f6e96f960cdbfe6868d9957a4613f704df.tar.gz
linhes_pkgbuild-8de064f6e96f960cdbfe6868d9957a4613f704df.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-simplejson')
-rw-r--r--abs/core/python_modules/python-simplejson/PKGBUILD37
-rw-r--r--abs/core/python_modules/python-simplejson/__changelog1
2 files changed, 38 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-simplejson/PKGBUILD b/abs/core/python_modules/python-simplejson/PKGBUILD
new file mode 100644
index 0000000..73dc754
--- /dev/null
+++ b/abs/core/python_modules/python-simplejson/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id$
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: David Moore <davidm@sjsoft.com>
+
+pkgbase=python-simplejson
+pkgname=('python2-simplejson')
+pkgver=3.6.5
+pkgrel=1
+pkgdesc='Simple, fast, extensible JSON encoder/decoder for Python'
+license=('MIT')
+arch=('x86_64' 'i686')
+url='http://undefined.org/python/#simplejson'
+makedepends=('python2-setuptools' 'git')
+source=("git://github.com/simplejson/simplejson.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+#package_python-simplejson() {
+# depends=('python')
+
+# cd simplejson
+# python setup.py install --root="$pkgdir"
+# install -Dm644 "$srcdir/simplejson/LICENSE.txt" \
+# "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+#}
+
+package_python2-simplejson() {
+ depends=('python2')
+
+ cd simplejson
+ python2 setup.py install --root="$pkgdir"
+ install -Dm644 "$srcdir/simplejson/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/python_modules/python-simplejson/__changelog b/abs/core/python_modules/python-simplejson/__changelog
new file mode 100644
index 0000000..488d3cf
--- /dev/null
+++ b/abs/core/python_modules/python-simplejson/__changelog
@@ -0,0 +1 @@
+PKGBUILD: rm py 3 stuff