summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-six/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-09-06 16:35:27 (GMT)
commit5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (patch)
treef13051093a52f47f5954c2ee2a783bc2f0f62f96 /abs/core/python_modules/python-six/PKGBUILD
parent8d35f28049488f2585ef765bf48e7a58958fd587 (diff)
parent04697136037cb5341ee6c051f8aaa265c0400c82 (diff)
downloadlinhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.zip
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.gz
linhes_pkgbuild-5669815ec3a539cf7b5ac7d8da2cbba3aeff44be.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-six/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-six/PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/abs/core/python_modules/python-six/PKGBUILD b/abs/core/python_modules/python-six/PKGBUILD
index 33093f7..56ca2de 100644
--- a/abs/core/python_modules/python-six/PKGBUILD
+++ b/abs/core/python_modules/python-six/PKGBUILD
@@ -4,28 +4,28 @@
# Contributer: Allan McRae <allan@archlinux.org>
pkgbase=python-six
-pkgname=('python2-six')
-pkgver=1.10.0
-pkgrel=3
+pkgname=('python2-six' 'python-six')
+pkgver=1.11.0
+pkgrel=1
pkgdesc="Python 2 and 3 compatibility utilities"
arch=('any')
url="http://pypi.python.org/pypi/six/"
license=('MIT')
-makedepends=('python2-setuptools')
-checkdepends=('python2-pytest' 'tk')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'tk')
source=("https://pypi.io/packages/source/s/six/six-$pkgver.tar.gz")
-md5sums=('34eed507548117b2ab523ab14b2f8b55')
+sha512sums=('33f246a2e987141e17e5edad9d3537cf3aba0cbdd0bc2a907ea52ce0d674b1474f29c3dd5cc26605fd960396054b189ca5f501708333cad234c223131483fe24')
build() {
cp -a six-$pkgver{,-py2}
}
check() {
-# cd "$srcdir"/six-$pkgver
-# py.test
+ cd "$srcdir"/six-$pkgver
+ python setup.py pytest
cd "$srcdir"/six-$pkgver-py2
- py.test2
+ python2 setup.py pytest
}
package_python-six() {