summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-six
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-10-27 20:28:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-10-27 20:28:27 (GMT)
commitf7b823f55a80b1498c30e9f3a47692a2329c4f09 (patch)
tree6de557714e6336282fbc0ab16c6578386dfc6654 /abs/core/python_modules/python-six
parent4c2a2e3504f472628285a989c7c9a76be6855f54 (diff)
parent01c1a60f3b7f93b3ed7404196c2cf798c4d8c674 (diff)
downloadlinhes_pkgbuild-f7b823f55a80b1498c30e9f3a47692a2329c4f09.zip
linhes_pkgbuild-f7b823f55a80b1498c30e9f3a47692a2329c4f09.tar.gz
linhes_pkgbuild-f7b823f55a80b1498c30e9f3a47692a2329c4f09.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-six')
-rw-r--r--abs/core/python_modules/python-six/PKGBUILD41
-rw-r--r--abs/core/python_modules/python-six/__changelog1
2 files changed, 42 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-six/PKGBUILD b/abs/core/python_modules/python-six/PKGBUILD
new file mode 100644
index 0000000..0e8986b
--- /dev/null
+++ b/abs/core/python_modules/python-six/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributer: Allan McRae <allan@archlinux.org>
+# Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
+
+pkgbase=python-six
+pkgname=('python2-six')
+pkgver=1.6.1
+pkgrel=2
+pkgdesc="Python 2 and 3 compatibility utilities"
+arch=('any')
+url="http://pypi.python.org/pypi/six/"
+license=('MIT')
+makedepends=('python2')
+source=(http://pypi.python.org/packages/source/s/six/six-$pkgver.tar.gz)
+md5sums=('07d606ac08595d795bf926cc9985674f')
+
+build() {
+ cd $srcdir
+ cp -r six-$pkgver six2-$pkgver
+}
+
+check() {
+# cd $srcdir/six-$pkgver
+# python3 setup.py check
+
+ cd $srcdir/six2-$pkgver
+ python2 setup.py check
+}
+
+#package_python-six() {
+# depends=('python')
+# cd $srcdir/six-$pkgver
+# python3 setup.py install --root "${pkgdir}" --optimize=1
+# install -Dm644 "${srcdir}/six-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+#}
+
+package_python2-six() {
+ depends=('python2')
+ cd $srcdir/six2-$pkgver
+ python2 setup.py install --root "${pkgdir}" --optimize=1
+ install -Dm644 "${srcdir}/six-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/abs/core/python_modules/python-six/__changelog b/abs/core/python_modules/python-six/__changelog
new file mode 100644
index 0000000..488d3cf
--- /dev/null
+++ b/abs/core/python_modules/python-six/__changelog
@@ -0,0 +1 @@
+PKGBUILD: rm py 3 stuff