summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-sphinx/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-10-27 20:28:27 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-10-27 20:28:27 (GMT)
commitf7b823f55a80b1498c30e9f3a47692a2329c4f09 (patch)
tree6de557714e6336282fbc0ab16c6578386dfc6654 /abs/core/python_modules/python-sphinx/PKGBUILD
parent4c2a2e3504f472628285a989c7c9a76be6855f54 (diff)
parent01c1a60f3b7f93b3ed7404196c2cf798c4d8c674 (diff)
downloadlinhes_pkgbuild-f7b823f55a80b1498c30e9f3a47692a2329c4f09.zip
linhes_pkgbuild-f7b823f55a80b1498c30e9f3a47692a2329c4f09.tar.gz
linhes_pkgbuild-f7b823f55a80b1498c30e9f3a47692a2329c4f09.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-sphinx/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-sphinx/PKGBUILD76
1 files changed, 76 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-sphinx/PKGBUILD b/abs/core/python_modules/python-sphinx/PKGBUILD
new file mode 100644
index 0000000..b4db703
--- /dev/null
+++ b/abs/core/python_modules/python-sphinx/PKGBUILD
@@ -0,0 +1,76 @@
+# $Id$
+# Maintainer: Sébastien Luttringer
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Fabio Volpe <volpefabio@gmail.com>
+
+pkgbase=python-sphinx
+pkgname=('python2-sphinx')
+pkgver=1.2.2
+pkgrel=4
+arch=('any')
+url='http://sphinx.pocoo.org/'
+license=('GPL')
+makedepends=(
+ 'python2-setuptools'
+ 'python2-docutils'
+ 'python2-jinja'
+ 'python2-pygments'
+)
+checkdepends=(
+ 'python2-nose'
+ 'texlive-latexextra'
+)
+source=("http://pypi.python.org/packages/source/S/Sphinx/Sphinx-$pkgver.tar.gz")
+md5sums=('3dc73ccaa8d0bfb2d62fb671b1f7e8a4')
+
+prepare() {
+ # souce duplication is required because makefile modify source code
+ # setyp.py --build tricks don't works well
+ cp -a Sphinx-$pkgver Sphinx-${pkgver}2
+ # change python2 interpreter
+ find Sphinx-${pkgver}2 -type f -exec \
+ sed -i '1s,^#! \?/usr/bin/\(env \|\)python$,#!/usr/bin/python2,' {} \;
+ # change sphinx-binaries name in source code
+# find Sphinx-${pkgver}2 -type f -name '*.py' -exec \
+# sed -ri 's,(sphinx-(:?build|apidoc|autogen|quickstart)),\12,' {} \;
+}
+
+build() {
+# msg2 'Python 3 version'
+# cd "$srcdir"/Sphinx-$pkgver
+# make PYTHON=python3 build
+ msg2 'Python 2 version'
+ cd "$srcdir"/Sphinx-${pkgver}2
+ make PYTHON=python2 build
+}
+
+check() {
+# msg2 'Python 3 version'
+# cd "$srcdir"/Sphinx-$pkgver
+# make PYTHON=python3 test
+# rm -r build/lib/tests
+ msg2 'Python 2 version'
+ cd "$srcdir"/Sphinx-${pkgver}2
+ make PYTHON=python2 test
+ rm -r build/lib/tests
+}
+
+#package_python-sphinx() {
+# pkgdesc='Python3 documentation generator'
+# depends=('python-jinja' 'python-pygments' 'python-docutils')
+# optdepends=('texlive-latexextra: for generation of PDF documentation')
+
+# cd Sphinx-$pkgver
+# python setup.py install --root="$pkgdir" --optimize=1
+#}
+
+package_python2-sphinx() {
+ pkgdesc='Python2 documentation generator'
+ depends=('python2-jinja' 'python2-pygments' 'python2-docutils')
+ optdepends=('texlive-latexextra: for generation of PDF documentation')
+
+ cd Sphinx-${pkgver}2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: