summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-urllib3
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python-urllib3
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-urllib3')
-rw-r--r--abs/core/python_modules/python-urllib3/LICENSE32
-rw-r--r--abs/core/python_modules/python-urllib3/PKGBUILD72
-rw-r--r--abs/core/python_modules/python-urllib3/__changelog1
3 files changed, 105 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-urllib3/LICENSE b/abs/core/python_modules/python-urllib3/LICENSE
new file mode 100644
index 0000000..5a44370
--- /dev/null
+++ b/abs/core/python_modules/python-urllib3/LICENSE
@@ -0,0 +1,32 @@
+Note from the ArchLinux Packager:
+The urllib3 source doesn't come with a license file. Its homepage
+does provide a link to the text of the MIT license, so I copied
+the following text to a file when building the package.
+
+------CUT------
+Open Source Initiative OSI - The MIT License:Licensing
+
+
+[OSI Approved License]
+
+The MIT License
+
+Copyright (c) <year> <copyright holders>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/abs/core/python_modules/python-urllib3/PKGBUILD b/abs/core/python_modules/python-urllib3/PKGBUILD
new file mode 100644
index 0000000..3f881d2
--- /dev/null
+++ b/abs/core/python_modules/python-urllib3/PKGBUILD
@@ -0,0 +1,72 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Patrice Peterson <runiq at archlinux dot us>
+# Contributor: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: BorgHunter <borghunter at gmail dot com>
+
+pkgbase=python-urllib3
+pkgname=(python2-urllib3)
+pkgver=1.21.1
+pkgrel=1
+pkgdesc="HTTP library with thread-safe connection pooling and file post support"
+arch=("any")
+url="https://github.com/shazow/urllib3"
+license=("MIT")
+makedepends=('python2-setuptools'
+ 'python2-ndg-httpsclient' 'python2-pyasn1'
+ 'python2-pyopenssl' 'python2-pysocks' 'python2-mock')
+checkdepends=('python2-nose' 'python2-tornado'
+ 'python2-coverage' 'python2-psutil')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/shazow/urllib3/archive/$pkgver.tar.gz")
+md5sums=('b0a2c692ea273dc120b209a027b0df3c')
+
+prepare() {
+ cp -a urllib3-$pkgver{,-py2}
+}
+
+build() {
+# cd "$srcdir"/urllib3-$pkgver
+# python setup.py build
+
+ cd "$srcdir"/urllib3-$pkgver-py2
+ python2 setup.py build
+
+ # Build with Python 2 since autodoc produces errors on Python 3
+# cd "$srcdir"/urllib3-$pkgver/docs
+# make SPHINXBUILD=sphinx-build2 html
+}
+
+check() {
+# cd "$srcdir"/urllib3-$pkgver
+# nosetests3 || warning "Tests failed"
+
+ cd "$srcdir"/urllib3-$pkgver-py2
+ nosetests2 || warning "Tests failed"
+}
+
+package_python-urllib3() {
+ depends=('python')
+ optdepends=('python-pysocks: SOCKS support')
+
+ cd urllib3-$pkgver
+ python setup.py install --root="$pkgdir"
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}
+
+package_python2-urllib3() {
+ depends=('python2')
+ optdepends=('python2-pysocks: SOCKS support')
+
+ cd urllib3-$pkgver-py2
+ python2 setup.py install --root="$pkgdir"
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}
+
+package_python-urllib3-doc() {
+ pkgdesc="urllib3 Documentation"
+
+ cd urllib3-$pkgver/docs
+ install -d "$pkgdir"/usr/share/doc
+ cp -r _build/html "$pkgdir"/usr/share/doc/python-urllib3
+ install -Dm644 ../LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+}
diff --git a/abs/core/python_modules/python-urllib3/__changelog b/abs/core/python_modules/python-urllib3/__changelog
new file mode 100644
index 0000000..49a28c7
--- /dev/null
+++ b/abs/core/python_modules/python-urllib3/__changelog
@@ -0,0 +1 @@
+PKGBUILD: don't build py 3 stuff or sphinx