summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python-zeroconf/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-10-25 17:05:26 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-10-25 17:05:26 (GMT)
commit7b41a9288f5d1332c8136df798bb8ca2465bc21c (patch)
tree8551ce40362a5d6191c918f1e5652f9350cce09f /abs/core/python_modules/python-zeroconf/PKGBUILD
parent5669815ec3a539cf7b5ac7d8da2cbba3aeff44be (diff)
parent0a4d5cece8f6b3148a61c6358026fdf2eb81cdb2 (diff)
downloadlinhes_pkgbuild-7b41a9288f5d1332c8136df798bb8ca2465bc21c.zip
linhes_pkgbuild-7b41a9288f5d1332c8136df798bb8ca2465bc21c.tar.gz
linhes_pkgbuild-7b41a9288f5d1332c8136df798bb8ca2465bc21c.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python-zeroconf/PKGBUILD')
-rw-r--r--abs/core/python_modules/python-zeroconf/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-zeroconf/PKGBUILD b/abs/core/python_modules/python-zeroconf/PKGBUILD
new file mode 100644
index 0000000..1b2e286
--- /dev/null
+++ b/abs/core/python_modules/python-zeroconf/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jelle van der Waa <jelle@archlinux.org>
+# Contributor: Maxim Andersson <thesilentboatman@gmail.com>
+
+pkgname=python-zeroconf
+pkgver=0.21.3
+pkgrel=1
+pkgdesc="A pure python implementation of multicast DNS service discovery"
+arch=('any')
+url="https://github.com/jstasiak/python-zeroconf"
+license=('LGPL')
+depends=('python' 'python-netifaces' 'python-six' 'python-ifaddr')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+source=("https://github.com/jstasiak/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('8c3aaed98f950b56c6e1aa440b56e0d48af49565cb4d7830a82cb3b01088aad8')
+
+build() {
+ cd "${pkgbase}-${pkgver}"
+ python3 setup.py build
+}
+
+package() {
+ cd "${pkgbase}-${pkgver}"
+
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
+
+check() {
+ cd "${pkgbase}-${pkgver}"
+ py.test .
+}
+
+# vim:set ts=2 sw=2 et: