summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-aniso8601
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python2-aniso8601
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python2-aniso8601')
-rw-r--r--abs/core/python_modules/python2-aniso8601/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-aniso8601/PKGBUILD b/abs/core/python_modules/python2-aniso8601/PKGBUILD
new file mode 100644
index 0000000..da44f5f
--- /dev/null
+++ b/abs/core/python_modules/python2-aniso8601/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-aniso8601
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A library for parsing ISO 8601 strings"
+arch=('any')
+depends=('python2' 'python2-dateutil')
+makedepends=('python2-setuptools')
+url="https://bitbucket.org/nielsenb/aniso8601"
+license=('BSD')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/a/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('d2610ecaab3bdfe51f74678c89c69cf7')
+sha256sums=('4fc462db59811f541bc25d865b86367153d8ce773ae75b16d54e2e1cd393b5cc')
+
+build() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg2 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg2 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}