summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-apscheduler
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python2-apscheduler
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python2-apscheduler')
-rw-r--r--abs/core/python_modules/python2-apscheduler/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-apscheduler/PKGBUILD b/abs/core/python_modules/python2-apscheduler/PKGBUILD
new file mode 100644
index 0000000..568e562
--- /dev/null
+++ b/abs/core/python_modules/python2-apscheduler/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Yaron de Leeuw < me@jarondl.net >
+# Maintained at : https://github.com/jarondl/aur-pkgbuilds-jarondl
+
+# Contributor: Shanto <shanto@hotmail.com>
+
+pkgname=python2-apscheduler
+_pkgname=APScheduler
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="In-process task scheduler with Cron-like capabilities"
+arch=('any')
+url="https://pypi.python.org/pypi/APScheduler"
+license=('MIT')
+depends=('python2'
+ 'python2-pytz'
+ 'python2-tzlocal'
+ 'python2-futures'
+ 'python2-funcsigs'
+ 'python2-six'
+ 'python2-setuptools'
+ )
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('5baa1195ba711868fae257612cf80372ff1124014ca896884bf132f75636f638')
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}