summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-flask-compress/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python2-flask-compress/PKGBUILD
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python2-flask-compress/PKGBUILD')
-rw-r--r--abs/core/python_modules/python2-flask-compress/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-flask-compress/PKGBUILD b/abs/core/python_modules/python2-flask-compress/PKGBUILD
new file mode 100644
index 0000000..266abf4
--- /dev/null
+++ b/abs/core/python_modules/python2-flask-compress/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+_pythonmod=Flask-Compress
+pkgname='python2-flask-compress'
+pkgver='1.4.0'
+pkgrel='1'
+pkgdesc='custom actions for flask to help manage your application'
+arch=('any')
+url='http://pypi.python.org/pypi/Flask-Compress/'
+license=('BSD')
+depends=('python2-flask')
+makedepends=('python2-setuptools')
+
+source=("https://pypi.io/packages/source/${_pythonmod:0:1}/${_pythonmod}/${_pythonmod}-$pkgver.tar.gz")
+sha1sums=('68b5eb124b02993c9466dfb2438e0ba79d2d5809')
+
+build() {
+ cd "Flask-Compress-${pkgver}"
+ python2 ./setup.py build
+}
+
+package() {
+ cd "Flask-Compress-${pkgver}"
+ python2 ./setup.py install --root="${pkgdir}" --prefix="/usr"
+}
+
+# vim:set ts=2 sw=2 et: