summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-flask-restplus086/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python2-flask-restplus086/PKGBUILD
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python2-flask-restplus086/PKGBUILD')
-rw-r--r--abs/core/python_modules/python2-flask-restplus086/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-flask-restplus086/PKGBUILD b/abs/core/python_modules/python2-flask-restplus086/PKGBUILD
new file mode 100644
index 0000000..226917b
--- /dev/null
+++ b/abs/core/python_modules/python2-flask-restplus086/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+pkgname='python2-flask-restplus086'
+pkgver='0.8.6'
+pkgrel='1'
+pkgdesc='custom actions for flask to help manage your application'
+arch=('any')
+url='http://pypi.python.org/pypi/Flask-Restplus/'
+license=('BSD')
+depends=('python2-flask-restful>=0.3.2' 'python2-jsonschema' 'python2-pytz' 'python2-aniso8601>=0.82')
+checkdepends=('python2-nose' 'python2-rednose' 'python2-blinker' 'python2-tzlocal' 'python2-mock')
+makedepends=('python2-setuptools')
+provides=('python2-flask-restplus=0.8.6')
+conflicts=('python2-flask-restplus')
+
+source=("http://pypi.python.org/packages/source/f/flask-restplus/flask-restplus-${pkgver}.tar.gz")
+sha1sums=('455788a4fa4cc9605760041974dbd7e4f46d9899')
+
+build() {
+ cd "flask-restplus-${pkgver}"
+ python2 ./setup.py build
+}
+
+check() {
+ cd "flask-restplus-${pkgver}"
+ python2 ./setup.py test
+}
+
+package() {
+ cd "flask-restplus-${pkgver}"
+ python2 ./setup.py install --root="${pkgdir}" --prefix="/usr"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim:set ts=2 sw=2 et: